aspose file tools*
The moose likes Web Services and the fly likes web service method working fine with soapui but not with client code Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "web service method working fine with soapui but not with client code" Watch "web service method working fine with soapui but not with client code" New topic
Author

web service method working fine with soapui but not with client code

Ankit V Agrawal
Greenhorn

Joined: Jan 27, 2012
Posts: 12
Hello Ranchers,

I'm facing a unique problem for which I'm not getting any solution.
I have a web service which I'm calling through my client code. The client code is generated using CXF. There are many different operations present in the web service. I'm not facing issues in calling all the ws methods, few of the methods run just fine and return results as expected. But there is onlye ONE method which returns null upon invocation. The same method returns a result thru SoapUI and the same code running on other environment also returns result.

Has any one faced this issue before ? I have already spent quite a lot of time trying to figure out what is happening.

Thanks,
Ankit


SCJP 5.0, SCWCD 5.0
William P O'Sullivan
Ranch Hand

Joined: Mar 28, 2012
Posts: 859

It depends on the format of the response packet.

You may need a custom converter.

Post the WSDL for the failing service if you can.

WP
Ankit V Agrawal
Greenhorn

Joined: Jan 27, 2012
Posts: 12
Ankit V Agrawal
Greenhorn

Joined: Jan 27, 2012
Posts: 12
i have changed the company name and the end point url. all other ws methods are working fine both thru code as well as soap ui.
Only adminRemoveNVPFromUser method is giving issues. It retruns null response when being called from the cxf client code, but returns correct result while called from Soap UI
 
jQuery in Action, 2nd edition
 
subject: web service method working fine with soapui but not with client code