aspose file tools*
The moose likes Applets and the fly likes Applets are not running after installing Java for OS X 2012-004 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "Applets are not running after installing Java for OS X 2012-004" Watch "Applets are not running after installing Java for OS X 2012-004" New topic
Author

Applets are not running after installing Java for OS X 2012-004

Rocky Seth
Greenhorn

Joined: Jun 20, 2012
Posts: 3
I updated my mac mini with latest OS X updates and the Java for OS X 2012-004 got installed .
now i am not able to run any applets in my application .
I have enabled the applet plugin and all settings looks fine .
I found out that the applet code needs to be fixed to work with the new update released by apple.
Can any one help me with what needs to be fixed in the applet code ?

thanks
raj
William P O'Sullivan
Ranch Hand

Joined: Mar 28, 2012
Posts: 859

Welcome,

Are you running them using AppletViewer or within a browser (on the mini)

I am not a Mac expert but there have been many questions and answers posted
here recently on the latest Lion "upgrade" and it's problems.


WP
Rocky Seth
Greenhorn

Joined: Jun 20, 2012
Posts: 3
I am running them through the browser - both firefox and safari .
i tried to load other applets like the one here - http://www.w3.org/People/mimasa/test/object/java/clock and they are loading fine in both browsers
William P O'Sullivan
Ranch Hand

Joined: Mar 28, 2012
Posts: 859

So the sample Applet works fine?

Are you hosting your Applets locally (on the mini)?
If that is the case I would start looking at the web/app server, and not the browser.

WP
Rocky Seth
Greenhorn

Joined: Jun 20, 2012
Posts: 3
Applet is running on a different server .
Everything worked fine before i installed the java update .
After installing the update . i had to renable the applet plugins in /Utilities/Java preferences but applets didnt load .
I tested with another applet on a website and it worked fine .My application is working fine on a windows [applets are getting loaded ]

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Applets are not running after installing Java for OS X 2012-004