This week's book giveaway is in the Design forum.
We're giving away four copies of Design for the Mind and have Victor S. Yocco on-line!
See this thread for details.
Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Using Sonatype Nexus proxy-host configuration with apache,Proxy repository downloads are very slow

 
d. singh
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am guessing,there must be some mechanism inside Nexus which is doing some scheduled cache cleaning after 24 hrs.I am not much sure but through our scheduled jenkins build that we placed is showingThis build is retriving artifact from Proxy and after building deploying to Host Nexus.
According to our current requirement,I am looking into setting through that we can stop cache cleanup.

Would you guys can given more information regarding that? How I can force nexus That it must not to clean cache from proxy
If we have not to expire Cache from proxy Nexus in any case(have good size of disk,etc),for that what are all settings we have to make so cache will never get expire or cleaned up?
Feel free to ask inputs.
Screen shot 2012-06-28 at 3.15.51 PM.png
Jenkin Build-time Graph
[Thumbnail for Screen shot 2012-06-28 at 3.15.51 PM.png]
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34178
340
Eclipse IDE Java VI Editor
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When configuring the proxy, you can set a few timeout time settings. One of them is max age. Setting it to -1 means not expiring.

See the screenshot here.
 
d. singh
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I AM REALLY GRATEFUL FOR YOU QUICK RESPONSE AND HELP.THANKS AGAIN


yes you are right ,by putting -1 in the expiration setting we can control cache cleanup.
but its not happening IN THIS CASE ,Is there any other way to control cache cleanup forcibly ?
Why its start deleting cache after every 24 hrs even I didn't enable scheduled cache expiration job into nexus?




 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34178
340
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Could a cron job of the like on the server be deleting the cache directory?
 
d. singh
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No crontab is there related to cache expiration. The one I have is following

0 * * * * /usr/local/bin/rotate-apache-logs


Is apache VirtualHost configuration can effect cache expiration or is there anything wrong in my VH conf ?following is my VirtualHost configuration. Please help me



<VirtualHost *:80>
ServerName sds-repo-int.qdc.intuit.com
ProxyPass /nexus http://sds-repo-int.qdc.intuit.com:8091/nexus
ProxyPassReverse /nexus http://sds-repo-int.qdc.intuit.com:8091/nexus
ErrorLog /repo/int/ApacheNexusLogs/error.log
CustomLog /repo/int/ApacheNexusLogs/access.log combinedio

</VirtualHost>

<VirtualHost *:8081>
ServerName sds-repo-int.qdc.intuit.com
ProxyPass /nexus http://sds-repo-int.qdc.intuit.com:8091/nexus
ProxyPassReverse /nexus http://sds-repo-int.qdc.intuit.com:8091/nexus
ErrorLog /repo/int/ApacheNexusLogs/error.log
CustomLog /repo/int/ApacheNexusLogs/access.log combinedio

</VirtualHost>

<VirtualHost *:8082>
ServerName pprdirmap302.corp.intuit.net
ProxyPass /nexus http://pprdirmap302.corp.intuit.net:8092/nexus
ProxyPassReverse /nexus http://pprdirmap302.corp.intuit.net:8092/nexus
ErrorLog /repo/dev/ApacheNexusLogs/error.log
CustomLog /repo/dev/ApacheNexusLogs/access.log combinedio

</VirtualHost>
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic