File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes Issue with IE7 and IE8 (possibily due to cookies) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Issue with IE7 and IE8 (possibily due to cookies)" Watch "Issue with IE7 and IE8 (possibily due to cookies)" New topic
Author

Issue with IE7 and IE8 (possibily due to cookies)

jimmy nautak
Greenhorn

Joined: Jul 12, 2012
Posts: 3
Hi, I am facing an issue with IE7 and IE8. The web appliction I am developing on is deployed on Weblogic 10.3. It uses wicket 4.18. Now on IE7/8, when I open the browser and login on domain (e.g. jam.comp.com mapped to 127.0.0.1) I am able to successfully reach to the home page. Now if I open up another tab in same IE window and try to login to subdomain (e.g. subdomain.jam.comp.com mapped to 127.0.0.1) I am pushed back to the login page. There is only occurring in IE 7 and 8 and working fine in firefox and chrome.

Now in the weblogic.xml I have this:

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE weblogic-web-app PUBLIC "-//BEA Systems, Inc.//DTD Web Application 9.1.0//EN" "http://www.bea.com/servers/wls910/dtd/weblogic-web-jar.dtd">
<weblogic-web-app>
<!-- WebLogic session descriptors -->
<session-descriptor>
<session-param>
<param-name>CookieName</param-name>
<param-value>MYCookie</param-value>
</session-param>
<session-param>
<param-name>PersistentStoreCookieName</param-name>
<param-value>MYCookie</param-value>
</session-param>
<session-param>
<param-name>PersistentStoreType</param-name>
<param-value>memory</param-value>
</session-param>
<session-param>
<param-name>CookiesEnabled</param-name>
<param-value>true</param-value>
</session-param>
<url-rewriting-enabled>false</url-rewriting-enabled>
<encode-session-id-in-query-params>false</encode-session-id-in-query-params>
</session-descriptor>
</weblogic-web-app>

If I open the subdomain (subdomain.jam.comp.com) in a new IE window with domain already open in another IE window, this issue does not occur and I am able to login through subdomain.

This seems to be an issue due to browser session cookie. If while login, for all the cookies whose name contains "ookie", I set - setMaxAge(0), setPath("/"), doamin this issue seems to resolved on local machine, but it happens on real deployment environment. Not sure if this sii\ the right approach to this issue.

Please share how can this issue be resolved.

Thanks in advance
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Issue with IE7 and IE8 (possibily due to cookies)