Win a copy of Learn Spring Security (video course) this week in the Spring forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

IE8 not handling cookies appropriately

 
jimmy nautak
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have two domains (primary and secondary) mapped to 127.0.0.1 in the hosts file. I have web application deployed on weblogic.

127.0.0.1 mysystem.comp.com

127.0.0.1 sub.mysystem.comp.com

Now I open up IE8 and go to primary domain i.e. ?http://mysystem.comp.com:7001/ and login successfuly. The session cookie I see in the response is

WLCookie=nYXNQQXRZp7dQdGXLy1dhylQZbtPdJFTjp9f81s5926PQyG04nPb!1416791498

Now I open another tab in the same browser window of IE8 and try to navigate to subdomain. Now the subdomain also has the cookie from primary domain. Though I try to clear it by setMaxAge(0), setPath("/"), setdomain, however this cookie does not clean out which I guess causes the weblogic to return me to the Login page on the second page for subdomain. I see two cookies in subdomain response

WLCookie=tCnnQQTY4vp3f2rnNlwWSHvXy1GylYFcXFTvx1192spLzTdjSNQZ!1416791498;
WLCookie=nYXNQQXRZp7dQdGXLy1dhylQZbtPdJFTjp9f81s5926PQyG04nPb!1416791498

This does not happen if instead of a tab I open up a new browser window.

This issue does not occur on firefox, chrome. Please provide a solution to this issue
 
jimmy nautak
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can someone please respond to this issue? Thanks in advance
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic