• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

gem installation error

 
Suganya Ram
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When im trying to install this gem(fxri), am getting this error.
Is anything needed to install this gem?

>gem install fxri --version 0.3.6
Building native extensions. This could take a while...
ERROR: Error installing fxri:
ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb install fxri --version 0.3.6
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/usr/bin/ruby
--with-fox-dir
--without-fox-dir
--with-fox-include
--without-fox-include=${fox-dir}/include
--with-fox-lib
--without-fox-lib=${fox-dir}/lib
--with-fxscintilla-dir
--without-fxscintilla-dir
--with-fxscintilla-include
--without-fxscintilla-include=${fxscintilla-dir}/include
--with-fxscintilla-lib
--without-fxscintilla-lib=${fxscintilla-dir}/lib


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/fxruby-1.6.15 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/fxruby-1.6.15/ext/fox16/gem_make.out
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34656
366
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Was there anything in the file referred to in the message? "Check the mkmf.log file for more
details. "
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34656
366
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm going to move this to our Scripting forum where people are more likely to know about Ruby.
 
Rusty Shackleford
Ranch Hand
Posts: 490
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you get RubyGems from your distros package manager? The only time I see this error is if you don't manually install it. It is easy, download the file at the main rails site, untar it, point your command prompt to the file and type ruby setup.rb
 
Rusty Shackleford
Ranch Hand
Posts: 490
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also, make sure you have ruby-devel installed.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic