wood burning stoves 2.0*
The moose likes Websphere and the fly likes WAS 7 deployment problem. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "WAS 7 deployment problem." Watch "WAS 7 deployment problem." New topic
Author

WAS 7 deployment problem.

Brian Mulholland
Ranch Hand

Joined: Mar 12, 2009
Posts: 61
I am attempting to deploy a REST webapp demo to our development environment so that other developers in the project can test against it. I somehow managed to deploy this app in a prior version, but I must have changed some things since then. I am deploying to WAS 7. I export my EAR, and go through the install wizard. It takes a half hour or so to upload and install the app, then another half hour when I hit finish despite the fact that this is a small demo sized app. Admittedly, it does have quite a few JARs in it.

Anyway, the process fails each time and in the log I am seeing:

[7/16/12 10:13:07:305 EDT] 000000a8 wtp E org.eclipse.jst.j2ee.commonarchivecore.internal.impl.WARFileImpl getDeploymentDescriptor An error occurred while processing the deployment descriptor, error message=IWAE0007E Could not load resource "WEB-INF/web.xml" in archive "eNoteWeb2.war"
[7/16/12 10:13:07:306 EDT] 000000a8 PersistentSto E WSWS7254E: Client binding information for the eNoteWeb2.war module in the eNoteWeb2EAR application could not be processed due to the following error: org.eclipse.jst.j2ee.commonarchivecore.internal.exception.DeploymentDescriptorLoadException: WEB-INF/web.xml.

My web.xml is pretty simple. The error doesn't really give me anything to go on.



 
It is sorta covered in the JavaRanch Style Guide.
 
subject: WAS 7 deployment problem.
 
Similar Threads
Spring configuration file not loaded via the application context but does for the servlet context.
getting error when deploying web app in weblogic 10.0
how to set domain namin on jboss as 4.0.5
Error JSF 2.1: java.io.FileNotFoundException:*/*.xhtml Not Found in ExternalContext
spring security 3.1 login not working.