aspose file tools*
The moose likes Struts and the fly likes Please help filter start error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Please help filter start error" Watch "Please help filter start error" New topic
Author

Please help filter start error

vijay jamadade
Ranch Hand

Joined: May 12, 2008
Posts: 241
I am implementing struts 2 framework. I am battling with filterstart error from last 8 hours. When i start my tomcat 5.5 it shows me following error.

SEVERE: Error filterStart
Jun 3, 2008 8:24:24 AM org.apache.catalina.core.StandardContext start
SEVERE: Context [/struts2tutorial] startup failed due to previous errors
Jun 3, 2008 8:24:25 AM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jun 3, 2008 8:24:25 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Jun 3, 2008 8:24:25 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/109 config=null
Jun 3, 2008 8:24:25 AM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Jun 3, 2008 8:24:26 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 3406 ms


Please help me guys, I have tried each & every thing to come out of it. Tell me all the possible reasons and remedies.
Thanks in advance.


Regards, Vijay Jamadade.
( Nothing is Impossible.)
Merrill Higginson
Ranch Hand

Joined: Feb 15, 2005
Posts: 4864
Try deploying the struts-blank-2.0.11.war file that comes with the download. Does the same thing happen? If not, you know it's something in your configuration.


Merrill
Consultant, Sima Solutions
vijay jamadade
Ranch Hand

Joined: May 12, 2008
Posts: 241
I am trying to deploy the same application you are talking about. But its giving me the same error. I added the struts-blank-2.0.11 project in the eclipse workspace and added the jars required in the classpath. Its compiling fine no probs. If i comment the filter settings in the web.xml of the application the tomcat is able to find the application context and displays the welcome page but after that as filterdispatcher is for mapping purpose it is unable to find the action as filter part is commented.

and if i uncomment the resource not found error thrown.

What should i do now?
vijay jamadade
Ranch Hand

Joined: May 12, 2008
Posts: 241
Hey friends i removed that filterstart error.
I dont know what was the exact problem but when i downloaded the fresh version of tomcat and then tried the problem was automatically solved. I think it was due to some conflict in the jar files in tomcat lib folder.

but now there is one more problem

type Status report
message There is no Action mapped for action name HelloWorld.
description The requested resource (There is no Action mapped for action name HelloWorld.) is not available.

tell me how to solve this now?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Please help filter start error