This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes BEA/Weblogic and the fly likes Target libraries to a new cluster using WLST Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Target libraries to a new cluster using WLST" Watch "Target libraries to a new cluster using WLST" New topic
Author

Target libraries to a new cluster using WLST

Mohtashim Shaikh
Ranch Hand

Joined: Jul 18, 2010
Posts: 43
I have written the below WLST script to generate / populate all the libraries in my domain as below.

*******************************************

*******************************************

java weblogic.WLST generate.py >/tmp/list.txt

OUTPUT:


Then i wrote target.py script to deploy these libraries to a new cluster as below. I read the library names from the list.txt and try to deploy them.



*****************************

However, when I try to deploy /assign these libraries to a new cluster some of the libraries get deployed fine [LIB_CommonUtility_WAR] however for the other libraries [bea_wls_async_response, LIB_GraniteAPIs] it complains as below.


*******************************


***************************************

As you can see above "'LIB_GraniteAPIs'" was populated in the list of libraries however when I am deploying by that very same name it complaints.

Please Explain us why ? Also, any alternate way to achieve this ?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Target libraries to a new cluster using WLST
 
Similar Threads
WLST- error when added log4j.jar in the classpath
Jython & NetBeans
error when creating a domain
Jython & NetBeans
unable to connect WLST to Node Manager