File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes Problems getting Java source working in Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Problems getting Java source working in Eclipse" Watch "Problems getting Java source working in Eclipse" New topic
Author

Problems getting Java source working in Eclipse

Malcolm Storey
Ranch Hand

Joined: Nov 09, 2008
Posts: 31
I have recently upgraded Eclipse to Juno, and downloaded the latest version of the Java source: JDK1.7.0_05.

Window/Prefs/Java/Installed JRE's shows jre7 (ticked), and jdk1.7.0_05\jre (not ticked)

Project/Props/Java Build Path show JRE System Library as jdk1.7.0_05 (and no others)

In source mode, F3 takes me into the the Java source (eg) JLabel.java, as expected.

BUT when I try to step in with the debugger it says "Source not found" and just shows Reflection.

(Windows 7 32bit.)

Thanks for any help.

Malcolm

I wouldn't join any Collection with an add() method that would accept me as a parameter
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18541
    
    8

Go into the build path for your project, select libraries, and find the JDK entry there. Open that up and one of the entries in the subtree should be "Source attachment". Edit that to point to the src.zip file in your JDK install directory.
Malcolm Storey
Ranch Hand

Joined: Nov 09, 2008
Posts: 31
The first 6 jars (resources.jar thru jfr.jar) already have Source attachment set to C:/Program Files/Java/jdk1.7.0_05/src.zip which I think is correct. The remaining 7 jars don't have anything, but I think that's normal.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problems getting Java source working in Eclipse
 
Similar Threads
Please some body help me, setting enviromental variables for Tomcat 7.
Eclipse/WSAD 5.1.1
error in eclipse
Installing Java Problem
Please help for Configuring Tomcat with Eclipse