aspose file tools*
The moose likes Android and the fly likes Android Emulator Throwing Error in Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Mobile » Android
Bookmark "Android Emulator Throwing Error in Eclipse" Watch "Android Emulator Throwing Error in Eclipse" New topic
Author

Android Emulator Throwing Error in Eclipse

Aditya Anil Sharma
Greenhorn

Joined: Jun 15, 2012
Posts: 9
Hi
I'm new to android and learning its programming from the official android website http://developer.android.com. I was going according to their tutorial but got stuck at one point.
I created the very first app as they told and made some changes so as to show the text box and a button. Created AVD on Eclipse Juno (Version 4.2.0) and ran the application but got below error:
[2012-08-14 22:11:41 - MyFirstApp] Android Launch!
[2012-08-14 22:11:41 - MyFirstApp] adb is running normally.
[2012-08-14 22:11:41 - MyFirstApp] Performing com.adi.myfirstapp.MainActivity activity launch
[2012-08-14 22:11:55 - MyFirstApp] Launching a new emulator with Virtual Device 'NewVD1'
[2012-08-14 22:12:02 - Emulator] Failed to create Context 0x3005
[2012-08-14 22:12:02 - Emulator] emulator: WARNING: Could not initialize OpenglES emulation, using software renderer.
[2012-08-14 22:12:03 - MyFirstApp] New emulator found: emulator-5554
[2012-08-14 22:12:03 - MyFirstApp] Waiting for HOME ('android.process.acore') to be launched...


Below is my code:

AndroidManifest.xml-


strings.xml-


MainActivity.java-


activity_main.xml-


I'm using Android Version 4.1 and have installed Android SDk properly.
I searched internet for solution and tried many options like deleting existing AVD and creating a new one, restarting Eclipse, but none of them worked.

Please guide me as in where am I going wrong.
suyash siddharth
Greenhorn

Joined: Aug 21, 2012
Posts: 1
I am facing the same problem. Did you found the solution?
lakthiagi narayanan
Greenhorn

Joined: Aug 22, 2012
Posts: 3
Its working fine with the above config. please clean your code & rebuild it. Go for a fresh run.
Aniket S. Kulkarni
Ranch Hand

Joined: Jun 15, 2011
Posts: 87

I am facing the same problem?
Did anyone find the answer?
Please help me!


Aniket Kulkarni
Oracle Certified Professional, Java SE 6 Programmer.
Aniket S. Kulkarni
Ranch Hand

Joined: Jun 15, 2011
Posts: 87

Hi!
I found the solution.
Open the AVD manager. Select the already created Virtual Device. Click on edit & add property GPU emulation set its value to yes.
Then restart the eclipse & run the app.

Solution

Hope this will help others too!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Android Emulator Throwing Error in Eclipse