This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Struts and the fly likes Tiles Error : java.lang.NullPointerException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Tiles Error : java.lang.NullPointerException" Watch "Tiles Error : java.lang.NullPointerException" New topic
Author

Tiles Error : java.lang.NullPointerException

Amit Goda
Ranch Hand

Joined: Jan 21, 2012
Posts: 37

Hello,

I am trying to implement tiles in my application. I have configured all files properly(as far as i am concerned, since i was learning it from tutorials on web) but when i run my application it gives me an java.lang.NullPointerException for Tiles. So can anyone please tell me whats wrong with my configuration.

I am getting the following error in console of eclipse



web.xml



tiles-defs.xml




struts.xml



Any Help will be highly appreciated!


AMiT
Yogesh Lonkar
Ranch Hand

Joined: Jul 17, 2012
Posts: 94

Are you using container such as Tomcat 6.x or 7.x ? if yes you don't need to specify these

all you need to do is just put struts.jar and all other jar files in /WEB-INF/lib i don't know that is solution for your case but from your looking at your web.xml file i think of this so try it


Learning some thing New Every Day
Amit Goda
Ranch Hand

Joined: Jan 21, 2012
Posts: 37

Hello Yogesh Thank you for your reply but that didn't solve my problem. I am using resin 4.0. But yes your suggestion will help me eradicate unwanted code in my application.

I solved the error. Actually it was occurring due to old .tld file in my tils-defs.xml and baseLayout.jsp files.

I replace the previous one



with this new one





You can easily see the difference between the older put tags versus newer put-attribute tags.

But the important thing to change is this URL <!DOCTYPE tiles-definitions PUBLIC "-//Apache Software Foundation//DTD Tiles Configuration 2.0//EN" "http://jakarta.apache.org/struts/dtds/tiles-config_2_0.dtd">

with

this one <!DOCTYPE tiles-definitions PUBLIC "-//Apache Software Foundation//DTD Tiles Configuration 2.0//EN" "http://tiles.apache.org/dtds/tiles-config_2_0.dtd">.

Hope it helps some other facing the same problem.

Cheers

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tiles Error : java.lang.NullPointerException
 
Similar Threads
struts2 action from tiles definition fired multiple times
Struts2 CannotRenderException
Facing an issue trying to use Struts 2.0.14 with Tiles 2.0.
Error page configured in web.xml not working
How to configure tiles with JSF+Struts2 Integration ?