This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Tomcat and the fly likes issues with load balancing application on tomcat Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "issues with load balancing application on tomcat" Watch "issues with load balancing application on tomcat" New topic
Author

issues with load balancing application on tomcat

Raj Seshu
Greenhorn

Joined: Aug 27, 2012
Posts: 2
Hello,

we have an application setup on unix where 2 seperate tomcat installations host the same application at different http, AJP and shutdown ports. we have a front facing apache http server where we have configured the loadbalancing through workers.properties and members poining to each tomcat in it.

this setup earlier was on apache 2, tomcat 5 and java 1.5 and it was working fine. later we upgraded to tomcat 7.0.25 and java 1.7 and now its not working. when both the tomcat instances are running, the application login page loads fine but when i login, it does not take me to application home but it again loads the login page where i see that the session is destroyed.

there are no changes in application but only the changes in the tomcat and java version (upgrades). when one of the instances is running with the upgraded setup, everything works fine. the problem happens only when both tomcat instances are up.

any idea / clue why i'm facing this problem and how to resolve it ???
Raj Seshu
Greenhorn

Joined: Aug 27, 2012
Posts: 2
also, in apache's httpd.conf file, do we need to explicitly point the workers.properties file even if its in the same folder as the httpd.conf is (both under /conf directory of apache)
 
 
subject: issues with load balancing application on tomcat
 
Similar Threads
Migrating WAS4.0 web application to WAS 5.0
Applet Gui is not updating inside JSP pages
Apache to Tomcat forwarding not working properly
Apache with Tomcat integration Passing Authenticated values
Session Replication with URL rewriting