aspose file tools*
The moose likes Java in General and the fly likes Error launching Jasper report Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Java in General
Bookmark "Error launching Jasper report" Watch "Error launching Jasper report" New topic
Author

Error launching Jasper report

Encarna Munoz
Greenhorn

Joined: Aug 31, 2012
Posts: 4
Hi!!
My name is Encarna and I’m from Spain. This is my first time in this forum and I have a problem and I can’t fix it.
We are working on a J2EE application, with eclipse 2, java 6, web dynamic module 2.4, Tomcat 5.5 and mysql 5.5. We arre using jasper reports, designed with iReport. All of them work properly but one. The extrange thing is that this report worked ok before, and we didn’t change anything in the code… (conf problem?). when we execute the report, the error is this:


And the console say this:


The action (.java method) that execute the report is this:




The error comes when .fillreport is called.

Report’s XML code is:



We have followed bloqueinforme1 values during the .java code. bloqueinforme1 is a list eith lists inside with the info for the report, and we have seen that the values are correct. The error seems to be in the subreport that the main report uses. I’ve been focused on a field (example Item) that is part of bloqueinforme1 . We can print and get Item value correctly but when we execute the report only using Item, the report says that it can’t find Item.
We don’t know the error cause; maybe is the list of lists (it can’t find the sublists); or a configuration problem (we had to change dynamic module from 3.0 to 2.4). Please, I am deperate!! Can you help me? Thank you very much!!

Cheers!!

Encarna Munoz
Greenhorn

Joined: Aug 31, 2012
Posts: 4

I am very sorry! The error on my first post was not the initial error.The initial error is this:


We have a lot of reports working fine. The only one that fails is the only one with subreports. when I compile the report (including subreports) with iReport, it compile ok, so I think is not a compilation problem. Our app generetes .japer files during runtime. This report worked fine before, but now... The path we use as a parameter to specify the place to generate the report and subreports, I mean .jasper files, is a relative path: ../../iReport. I tried absolute paths like, but when I try this path:




get this error:



'm working on thisa problem since weeks ago.. I need help, everything you can tell me would be great. Thank you very much!!


Vishal Shaw
Ranch Hand

Joined: Aug 09, 2012
Posts: 179
Hi,

please follow this post.

Seems like you and Unai are working on the same module

Vishal


Programming is about thinking, NOT coding
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error launching Jasper report