aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes unabled to correctly excecute integration-test Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "unabled to correctly excecute integration-test" Watch "unabled to correctly excecute integration-test" New topic
Author

unabled to correctly excecute integration-test

Adrien Ruffie
Ranch Hand

Joined: Jan 14, 2009
Posts: 90
Hello all,

I use maven/cargo/selenium/... in order to launch integration-test.

but when I launch: mvn integration-test

Maven process wait indefinitely in [INFO] [cargo:run {execution: start-container}] ...
And doesn't launch Testng integration test ... any one see why ?

[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building edeal-integration-tests
[INFO] task-segment: [clean, integration-test]
[INFO] ------------------------------------------------------------------------
[INFO] [clean:clean {execution: default-clean}]
[INFO] Deleting directory C:\Java\test\integration-tests\target
[INFO] [compiler:testCompile {execution: default}]
[INFO] Compiling 2 source files to C:\Java\test\integration-tests\target\test-classes
[INFO] [site:attach-descriptor {execution: default-attach-descriptor}]
[INFO] [cargo:run {execution: start-container}]

My following pom.xml:



Best regards

Adrien


SCJP 5, SCDJWS 5
http://adrien-ruffie.blogspot.com
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

Try running with the -X option, the cargo plugin should give you more details about what it is doing. That might give you a clue as to where it is hung.


JBoss In Action
Adrien Ruffie
Ranch Hand

Joined: Jan 14, 2009
Posts: 90
Thank Peter, I have forgotten this option ...

I think no test is launched ... why, I don't understand because my surefire plugin which must excecute integration-test is bound
to



Here all debug traces: [Peter: placed into attached zip]



[Download maven_output.zip] Download

Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

I think that the issue is with cargo and that he deploy is never completing. Or it could just be that the output was truncated when you uploaded it. But then again, I don't have the time to go through the output in detail.

By the way, never post such a long output again. Instead, redirect your output to a file, zip it up, and attach the zip file to the post.
Adrien Ruffie
Ranch Hand

Joined: Jan 14, 2009
Posts: 90
I see, thank Peter for attachment file.

But I have tried different options, several configurations and I don't understand, because Cargo is correctly started (I can access to the webapp) but no test is run ...
I think I a phase/goal problem, but I don't see the correct solution.
 
wood burning stoves
 
subject: unabled to correctly excecute integration-test