• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

UnsupportedOperationException

 
Ravikanth thota
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,
I am using SQLServer database and Jboss server. While accessing the database iam getting the following error. I tried with both sqljdbc.jar and sqljdbc4.jar still iam getting the same error. can any one help me regarding this.

java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.6 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.
00:13:40,069 ERROR [STDERR] at com.microsoft.sqlserver.jdbc.SQLServerConnection.<init>(SQLServerConnection.java:223)
00:13:40,069 ERROR [STDERR] at com.microsoft.sqlserver.jdbc.SQLServerDriver.connect(SQLServerDriver.java:840)


 
Ashwini Kashyap
Ranch Hand
Posts: 90
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

This is mostly due to JDK version issue.
Which version of JDK are you using?

Make use JDK 1.6 version or above and sqljdbc4.jar.

Hope this helps.

Thanks and Regards,
Ashwini Kashyap | akashyap@infocepts.com | www.infocepts.com
 
Ravikanth thota
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ashwini Kashyap wrote:Hi,

This is mostly due to JDK version issue.
Which version of JDK are you using?

Make use JDK 1.6 version or above and sqljdbc4.jar.

Hope this helps.

Thanks and Regards,
Ashwini Kashyap | akashyap@infocepts.com | www.infocepts.com



I am using jdk1.6.0_30 and sqljdbc4.jar .. still iam getting the same problem
 
Ashwini Kashyap
Ranch Hand
Posts: 90
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try deleting work folder within the server and restart it.

Thanks and Regards,
Ashwini Kashyap | akashyap@infocepts.com | www.infocepts.com
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic