wood burning stoves 2.0*
The moose likes Struts and the fly likes problem in struts Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "problem in struts" Watch "problem in struts" New topic
Author

problem in struts

joseph prabhu
Ranch Hand

Joined: Feb 26, 2008
Posts: 162
i am using netbeans 6.1 with tomcat 6.0 of strut 1.2.9.

index.jsp contains
<jsp:forward page="Welcome.do"/>

my strutsconfig.xml contains




but when i run the program as giving the url as
http://localhost:8080/Sample/

it gives 404 error. what will be error
Ananth Chellathurai
Ranch Hand

Joined: Nov 21, 2007
Posts: 349

I think the problem may be in your web.xml, do you have your index.jsp mentioned in the web.xml? Have you mentioned the servlet-name within servlet-mapping like,




Ananth Chellathurai


Ananth Chellathurai [Walk on software]
Sagar Rohankar
Ranch Hand

Joined: Feb 19, 2008
Posts: 2902
    
    1

Look at the welcome-file-list tag in your web.xml, it may not be correctly defined !


[LEARNING bLOG] | [Freelance Web Designer] | [and "Rohan" is part of my surname]
hildich kilal
Ranch Hand

Joined: Aug 25, 2008
Posts: 44
Like Ananth said , check web.xml. See if you have defined some index.jsp as welcome file or not?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: problem in struts