aspose file tools*
The moose likes Struts and the fly likes Backporting Struts 2 to JDK1.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Backporting Struts 2 to JDK1.4" Watch "Backporting Struts 2 to JDK1.4" New topic
Author

Backporting Struts 2 to JDK1.4

Priyanka Dandekar
Ranch Hand

Joined: Aug 06, 2008
Posts: 52
Hi Experts,
I am using Struts 2 and want to run Struts 2 on JDK 1.4.
When I searched thru the Struts 2 site it shows me JDK 1.4 jar files to download. But even after using those jar files my application is not working on JDK 1.4. I am getting invalid class version errors.

I am not sure what is the problem, but looks like some jars are still compiled in JDK 1.5.

I did not find much help on Struts 2 site on this, any help whould be appreciated.


Priya - Mockup Tool | Java | Struts2 | Lucene
Sachin Joshi
Ranch Hand

Joined: Aug 06, 2008
Posts: 83

Struts 2 backporting package contains the core jars, If you require the plugins also then you need to translate the plugin jars to JDK 1.4 format. This can be done using Retrotranslator.

This is the link [Backporting Struts 2 ] which demonstrates how you can Backport Struts 2 Dependancies to JDK 1.4 or JDK 1.3 using retrotranslation
[ September 01, 2008: Message edited by: Sachin Joshi ]

Web Development Tips and Tutorials - By Sachin
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42908
    
  69
If you want to use a recent framework, why not use a more recent JRE, like Java 5? There are interesting other web frameworks -like Stripes- that require Java 5.
Priyanka Dandekar
Ranch Hand

Joined: Aug 06, 2008
Posts: 52
We have an existing application where we need to add some more ndependant features ... and existing app is deployed on JDK 1.4. It will be more efforts to move whole app to JDK1.5, and I am not the one who can take this decision of moving to JDK1.5 so thought of using 1.4 compatible framework....any good options smilar to struts 2 in JDK 1.4
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Backporting Struts 2 to JDK1.4