This week's book giveaway is in the OCAJP 8 forum.
We're giving away four copies of OCA Java SE 8 Programmer I Study Guide and have Edward Finegan & Robert Liguori on-line!
See this thread for details.
The moose likes Testing and the fly likes  Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA Java SE 8 Programmer I Study Guide this week in the OCAJP 8 forum!
JavaRanch » Java Forums » Engineering » Testing
Bookmark " "Test reports were found but none of them are new. Did tests run?"" Watch " "Test reports were found but none of them are new. Did tests run?"" New topic
Author

"Test reports were found but none of them are new. Did tests run?"

nitss bhavsar
Ranch Hand

Joined: Jan 09, 2012
Posts: 55
Hi,
I have a problem with publishing JUnit test results from one of our
projects.

The log says,

Recording test results
Test reports were found but none of them are new. Did tests run?
For example, /export/home/hudson/client/jobs/Orchestrator 840 Support/workspace/test-result/TEST-com.ftisoft.framework.TestOIDGenerator.xml is 2 mo 22 days old


does anybody have a hint ??how to resolve it?


regards,
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 32635
    
215

It does sound like the unit tests aren't being run or a report isn't being generated. How do you think the tests/reporting is being run? Ant? Maven? Something else?


[OCA 8 book] [Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Other Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, TOGAF part 1 and part 2
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: "Test reports were found but none of them are new. Did tests run?"
 
It's not a secret anymore!