This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes JForum and the fly likes Canot see any topics after upgrading from Jforum 2.1.6 to 2.1.9 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Canot see any topics after upgrading from Jforum 2.1.6 to 2.1.9" Watch "Canot see any topics after upgrading from Jforum 2.1.6 to 2.1.9" New topic
Author

Canot see any topics after upgrading from Jforum 2.1.6 to 2.1.9

P Taylor
Greenhorn

Joined: Sep 28, 2012
Posts: 2
I have just upgraded to Jforum 2.1.9 , I can login but although it says 'Our users have posted a total of 11,205' messages , no messages, topics or forums are listed. I'm using Tomcat 7.0.30 and MySql 5.0.77, I did the upgrade as follows:

Ran mysqldump on my database
Created a new database and populated with output of mysqldump
Modified my existing 2.1.6 installation to use new database and checked that it still worked
Unzipped jforum-2.1.9.zip to local directory
Changed 2.1.6 installation to loook back at its original database
Ran mysql_2.1.6_to_2.1.7.sql against the new database
Ran mysql_2.1.7_to_2.1.8.sql against the new database
(Couldnt see an upgrade script for 2.1.8 to 2.1.9)
Created META-INF/context.xml (which defines a data source for new database, not sur eif required)
Copied WEB-INF/config/jforum-custom.conf from my 2.1.6 installation into WEB-INF/config in jforum2.1.9 directory in same place and modifed to point to new database
Modified forum.link and homepage link to point to new deploy path
Deployed this modified version


So I now have deployed:

http://machinename/forum (2.1.6 pointing to old database)
http://machinename/forum2.1.9 (2.1.9 pointing to new database)

As I said earlier I can get to http://machinename/forum2.1.9 and login but no topics/messages ectera are listed. Similarly if I go into Admin Control Panel Users and Groups looks okay but Forums is empty

If I go to the database itself and look at jforum_topics and jforum_forums the data is there.

I then noticed the lucene section in Admin and that the Number of documents was zero. So I configured a date range and created a new index, the Number of Documents field increased. If I then go back to the forum and do a search the search says it has found some documents but still does not show any of the results.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Canot see any topics after upgrading from Jforum 2.1.6 to 2.1.9
 
Similar Threads
upgrade from 2.0.2 to 2.1.6
User Details CVS Bug
Several JForum shares same user database
cannot install 2.1.7 on Linux without __index.redirect
upgrade from 2.1.5 to 2.1.6 database problem