This week's book giveaway is in the Jobs Discussion forum.
We're giving away four copies of Soft Skills and have John Sonmez on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes [JBOSS] DatasourceBinding problem (EclipseLink) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "[JBOSS] DatasourceBinding problem (EclipseLink)" Watch "[JBOSS] DatasourceBinding problem (EclipseLink)" New topic
Author

[JBOSS] DatasourceBinding problem (EclipseLink)

alp carsikarsi
Ranch Hand

Joined: Dec 27, 2005
Posts: 40
Hello,

I'm writing a sip application which will run in JBOSS Mobicent. I'm using eclipse-link (JPA API) for database issues. When i tried to deploy my application to JBOSS i'm getting following exception.
I tried many combinations but i failed. What am i doing wrong ?

MY persistence.xml :



stsCore-ds.xml :


i also put stsCore-ds.xml into WEB-INF folder:


MY EXCEPTION (JBOSS) :

PLOYMENTS MISSING DEPENDENCIES:
Deployment "persistence.unit:unitName=#stsCore" is missing the following dependencies:
Dependency "jboss.jca:name=stsCore,service=DataSourceBinding" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.jca:name=stsCore,service=DataSourceBinding' **")

DEPLOYMENTS IN ERROR:
Deployment "jboss.jca:name=stsCore,service=DataSourceBinding" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.jca:name=stsCore,service=DataSourceBinding' **

at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:993)
at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:939)
at org.jboss.deployers.plugins.main.MainDeployerImpl.checkComplete(MainDeployerImpl.java:873)
at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.checkComplete(MainDeployerAdapter.java:128)
at org.jboss.system.server.profileservice.hotdeploy.HDScanner.scan(HDScanner.java:369)
at org.jboss.system.server.profileservice.hotdeploy.HDScanner.run(HDScanner.java:255)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:351)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:165)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:267)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16303
    
  21

I think this is more of a JBoss question than a Portal/Portlet question, so I'm moving it.

I'm not too sure about your JNDI pathname.


Customer surveys are for companies who didn't pay proper attention to begin with.
 
Don't get me started about those stupid light bulbs.
 
subject: [JBOSS] DatasourceBinding problem (EclipseLink)