File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes findOrCreateRJVM is not found int ServerURL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "findOrCreateRJVM is not found int ServerURL" Watch "findOrCreateRJVM is not found int ServerURL" New topic
Author

findOrCreateRJVM is not found int ServerURL

Gaurav Aneja
Greenhorn

Joined: Oct 19, 2012
Posts: 3
Hi all

I am trying to execute Soap Ui project on unix machine using command line. The project loads successfully and the groovy script starts executing but when the script pushes the data on JMS queue , I get the following error :

ERROR [SoapUI] An error occured [weblogic.rjvm.ServerURL.findOrCreateRJVM(ZLjava/lang/String;Lweblogic/rmi/spi/HostID;IZ)Lweblogic/rjvm/RJVM;], see error log for details
java.lang.NoSuchMethodError: weblogic.rjvm.ServerURL.findOrCreateRJVM(ZLjava/lang/String;Lweblogic/rmi/spi/HostID;IZ)Lweblogic/rjvm/RJVM;
at weblogic.jndi.WLInitialContextFactoryDelegate$1.run(WLInitialContextFactoryDelegate.java:345)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
at weblogic.security.service.SecurityManager.runAs(Unknown Source)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:340)
at weblogic.jndi.Environment.getContext(Environment.java:315)
at weblogic.jndi.Environment.getContext(Environment.java:285)
at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:117)
at javax.naming.spi.NamingManager.getInitialContext(Unknown Source)
at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
at javax.naming.InitialContext.init(Unknown Source)
at javax.naming.InitialContext.<init>(Unknown Source)
at hermes.JNDIContextFactory.createContext(JNDIContextFactory.java:261)
at hermes.JNDIConnectionFactory.createConnection(JNDIConnectionFactory.java:80)
at com.eviware.soapui.impl.wsdl.submit.transports.jms.JMSConnectionHolder.createConnection(JMSConnectionHolder.java:86)
at com.eviware.soapui.impl.wsdl.submit.transports.jms.JMSConnectionHolder.<init>(JMSConnectionHolder.java:66)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at org.codehaus.groovy.reflection.CachedConstructor.invoke(CachedConstructor.java:77)
at org.codehaus.groovy.runtime.callsite.ConstructorSite$ConstructorSiteNoUnwrapNoCoerce.callConstructor(ConstructorSite.java:102)
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallConstructor(CallSiteArray.java:54)
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:182)
at GenericJmsPush_pop.run(GenericJmsPush_pop.groovy:47)
at groovy.lang.GroovyShell.evaluate(GroovyShell.java:580)
at groovy.lang.GroovyShell.evaluate(GroovyShell.java:627)
at groovy.lang.Script.evaluate(Script.java:219)
at groovy.lang.Script$evaluate.callCurrent(Unknown Source)
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallCurrent(CallSiteArray.java:46)
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:133)
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:141)
at Script1.run(Script1.groovy:420)
at com.eviware.soapui.support.scripting.groovy.SoapUIGroovyScriptEngine.run(SoapUIGroovyScriptEngine.java:96)
at com.eviware.soapui.impl.wsdl.teststeps.WsdlGroovyScriptTestStep.run(WsdlGroovyScriptTestStep.java:149)
at com.eviware.soapui.impl.wsdl.support.AbstractTestCaseRunner.runTestStep(AbstractTestCaseRunner.java:238)
at com.eviware.soapui.impl.wsdl.testcase.WsdlTestCaseRunner.runCurrentTestStep(WsdlTestCaseRunner.java:48)
at com.eviware.soapui.impl.wsdl.support.AbstractTestCaseRunner.internalRun(AbstractTestCaseRunner.java:147)
at com.eviware.soapui.impl.wsdl.support.AbstractTestCaseRunner.internalRun(AbstractTestCaseRunner.java:42)
at com.eviware.soapui.impl.wsdl.support.AbstractTestRunner.run(AbstractTestRunner.java:135)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
12:27:17,520 INFO [log] Error :javax.jms.JMSException: weblogic.rjvm.ServerURL.findOrCreateRJVM(ZLjava/lang/String;Lweblogic/rmi/spi/HostID;IZ)Lweblogic/rjvm/RJVM;


I have tried placing wlfullclient in hermes's lib folder as well as soap ui's lib but I get the same error again.
Please Help!
Pablo Abbate
Ranch Hand

Joined: Aug 06, 2012
Posts: 30

This kind of errors happen when you have an api-jar and an impl-jar with misplaced versions.

For example.

api-1.0.3.jar
impl-1.0.1.jar

Please check that.


Nissi Group, Posicionamiento Web, Desarrollo de Software, DiseƱo Web
Blog , LinkedIn
Gaurav Aneja
Greenhorn

Joined: Oct 19, 2012
Posts: 3
Hi Pablo

Thanks for your reply. I looked up in the lib folder of Soap Ui and HermesJms but i could not find any such jars that you have mentioned.

Are you suggesting that the error could be because of different versions of jars in the lib folders?

I have added wlfulclient, weblogic, weblogic_10 jars afterwards . All other jars have remained the same since installation.

And its working on windows command line platform with the same jars.

Please suggest
Gaurav Aneja
Greenhorn

Joined: Oct 19, 2012
Posts: 3
Hi..

The issue has been resolved.

I just removed weblogic.jar from the HermesJms lib and it worked. I read somewhere that it is not compatible with clients.

Thanks
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: findOrCreateRJVM is not found int ServerURL
 
Similar Threads
Change password for user in WebLogic 8.1 with Java
can't run jstl in jsp
Struts application. Environment variables Problem it seems!
No class DefFound error in EJB3.0 running in weblogic 10.0
Getting CommunicationException