File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes Started the windows service for admin server successfully, but the Admin Server is not started Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Started the windows service for admin server successfully, but the Admin Server is not started" Watch "Started the windows service for admin server successfully, but the Admin Server is not started" New topic
Author

Started the windows service for admin server successfully, but the Admin Server is not started

kona krishnakumar
Ranch Hand

Joined: Dec 03, 2011
Posts: 32
Hi All,

Issue: Admin Server not starting

Recent changes: started the admin server in command prompt and killed the process forcefully and then created the windows

service for admin server.

Problem no.1: I created boot.properties in .......\AdminServer\security. Post creating boot.properties also Admin server is

asking to enter credentials in the command propmt,by entering the same started the admin server. But the credentials in

boot.properties are not encrypted,

What would be the reason for this?

Problem no.2:

I Installed the windows service, post killing the admin server process using taskkill command.Below is the procedure I

followed to create the service for admin server.

======================================================================
1. I tried to start the service using the following command

net start "service name".

Intially service was not started, but later given the service name in inverted commas, then the service was successfully

started. But when I checked the port number of admin server using netstat command, it was not showing admin server port

number. So I came to conclusion that, Admin server was not started.
2. Later I thought I had Not given the necessary details when installing the service, so I given java home details, but no

luck
3. Later enabled production and startup mode in service script, no luck.
4. I verified as the service also registered in "regedit".
5. Later I added WLS_USER and Password parameters in service script and then started the service and in fraction of seconds

one process was created with 9001 port and then the same process was automatically disappeared as per below netstat report

from command prompt.
--------------------------------------------------------------
D:\Oracle\Middleware\wlserver_10.3\server\bin>netstat -ano | findstr 9001
TCP 127.0.0.1:3250 127.0.0.1:9001 SYN_SENT 3216
D:\Oracle\Middleware\wlserver_10.3\server\bin>netstat -ano | findstr 9001
no statistics were displayed now.....
-------------------------------------------------------------------------------
6. I verified as the service was successfully installed by using below command

Intially I had set the below path and then executed the debug command

D:\Oracle\Middleware\wlserver_10.3\server\bin>set PATH=D:\Oracle\Middleware\wlserver_10.3\server\bin:%PATH%

D:\Oracle\Middleware\wlserver_10.3\server\bin>beasvc -debug "beasvc base_domain_AdminServer"

The above command verified the installed service and tried to start the server automatically and thrown the following error

==============================================================================


Delay: ....... 0

Thread created successfully!
<Oct 22, 2012 8:13:56 AM GMT+05:30> <Info> <Security> <BEA-090905> <Disabling Cr
yptoJ JCE Provider self-integrity check for better startup performance. To enabl
e this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=tru
e>
<Oct 22, 2012 8:13:57 AM GMT+05:30> <Info> <Security> <BEA-090906> <Changing the
default Random Number Generator in RSA CryptoJ from ECDRBG to FIPS186PRNG. To d
isable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true>
<Oct 22, 2012 8:14:01 AM GMT+05:30> <Info> <WebLogicServer> <BEA-000377> <Starti
ng WebLogic Server with Java HotSpot(TM) Server VM Version 16.3-b01 from Sun Mic
rosystems Inc.>
<Oct 22, 2012 8:14:13 AM GMT+05:30> <Info> <Management> <BEA-141107> <Version: W
ebLogic Server 10.3.5.0 Fri Apr 1 20:20:06 PDT 2011 1398638 >
<Oct 22, 2012 8:14:19 AM GMT+05:30> <Emergency> <Management> <BEA-141151> <The a
dmin server could not be reached at http://localhost:9001.>;
<Oct 22, 2012 8:14:20 AM GMT+05:30> <Info> <Configuration Management> <BEA-15001
8> <This server is being started in managed server independence mode in the abse
nce of the admin server.>
<Oct 22, 2012 8:14:21 AM GMT+05:30> <Notice> <WebLogicServer> <BEA-000365> <Serv
er state changed to STARTING>
<Oct 22, 2012 8:14:21 AM GMT+05:30> <Info> <WorkManager> <BEA-002900> <Initializ
ing self-tuning thread pool>
<Oct 22, 2012 8:14:23 AM GMT+05:30> <Notice> <Log Management> <BEA-170019> <The
server log file D:\Oracle\Middleware\user_projects\domains\base_domain\servers\A
dminServer\logs\AdminServer.log is opened. All server side log events will be wr
itten to this file.>
<Oct 22, 2012 8:14:37 AM GMT+05:30> <Notice> <Security> <BEA-090082> <Security i
nitializing using security realm myrealm.>
<Oct 22, 2012 8:14:40 AM GMT+05:30> <Error> <Configuration Management> <BEA-1500
00> <An error occurred while establishing a connection back to the adminstration
server t3://127.0.0.1:9001 during startup. Since bootstrap succeeded check that
t3://127.0.0.1:9001 uniquely identifies the administration server.
javax.naming.ServiceUnavailableException [Root exception is java.rmi.NoSuchObjec
tException: The object identified by: '31' could not be found. Either it was ha
s not been exported or it has been collected by the distributed garbage collecto
r.]
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(Exceptio
nTranslator.java:70)
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(Exceptio
nTranslator.java:32)
at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLIni
tialContextFactoryDelegate.java:788)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialReference(WLI
nitialContextFactoryDelegate.java:431)
at weblogic.jndi.Environment.getInitialReference(Environment.java:245)
Truncated. see log file for complete stacktrace
Caused By: java.rmi.NoSuchObjectException: The object identified by: '31' could
not be found. Either it was has not been exported or it has been collected by t
he distributed garbage collector.
at weblogic.rmi.internal.OIDManager.getServerReference(OIDManager.java:2
51)
at weblogic.rmi.extensions.server.ServerHelper.getLocalInitialReference(
ServerHelper.java:429)
at weblogic.rmi.extensions.StubFactory.getStub(StubFactory.java:131)
at weblogic.rmi.extensions.StubFactory.getStub(StubFactory.java:124)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialReference(WLI
nitialContextFactoryDelegate.java:427)
Truncated. see log file for complete stacktrace
>
<Oct 22, 2012 8:14:40 AM GMT+05:30> <Critical> <WebLogicServer> <BEA-000362> <Se
rver failed. Reason:

There are 1 nested errors:

javax.naming.ServiceUnavailableException [Root exception is java.rmi.NoSuchObjec
tException: The object identified by: '31' could not be found. Either it was ha
s not been exported or it has been collected by the distributed garbage collecto
r.]
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(Exceptio
nTranslator.java:70)
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(Exceptio
nTranslator.java:32)
at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLIni
tialContextFactoryDelegate.java:788)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialReference(WLI
nitialContextFactoryDelegate.java:431)
at weblogic.jndi.Environment.getInitialReference(Environment.java:245)
at weblogic.server.channels.RemoteChannelServiceImpl.registerInternal(Re
moteChannelServiceImpl.java:173)
at weblogic.server.channels.RemoteChannelServiceImpl.registerForever(Rem
oteChannelServiceImpl.java:146)
at weblogic.protocol.ConnectMonitorFactory.registerForever(ConnectMonito
rFactory.java:88)
at weblogic.management.provider.MSIService.registerForReconnectToAdminSe
rver(MSIService.java:174)
at weblogic.management.mbeanservers.compatibility.internal.Compatibility
MBeanServerService.start(CompatibilityMBeanServerService.java:154)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)
Caused by: java.rmi.NoSuchObjectException: The object identified by: '31' could
not be found. Either it was has not been exported or it has been collected by t
he distributed garbage collector.
at weblogic.rmi.internal.OIDManager.getServerReference(OIDManager.java:2
51)
at weblogic.rmi.extensions.server.ServerHelper.getLocalInitialReference(
ServerHelper.java:429)
at weblogic.rmi.extensions.StubFactory.getStub(StubFactory.java:131)
at weblogic.rmi.extensions.StubFactory.getStub(StubFactory.java:124)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialReference(WLI
nitialContextFactoryDelegate.java:427)
... 9 more

>
<Oct 22, 2012 8:14:40 AM GMT+05:30> <Notice> <WebLogicServer> <BEA-000365> <Serv
er state changed to FAILED>
<Oct 22, 2012 8:14:40 AM GMT+05:30> <Error> <WebLogicServer> <BEA-000383> <A cri
tical service failed. The server will shut itself down>
<Oct 22, 2012 8:14:40 AM GMT+05:30> <Notice> <WebLogicServer> <BEA-000365> <Serv
er state changed to FORCE_SHUTTING_DOWN>
=============================================================================================================

For you reference parameters in reg editry
-------------------------------

CmdLine in registry
---------------
-server -Xms32m -Xmx200m -XX:MaxPermSize=128m -XX:+UseSpinning -classpath

"D:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest_classpath\weblogic_patch.jar;D:\Java\jdk1.6.0_20\lib\tools.ja

r;D:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;D:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;D:\Oracle\MI

DDLE~1\modules\features\weblogic.server.modules_10.3.5.0.jar;D:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;D:\Orac

le\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;D:\Oracle\MIDDLE~1\modules\NETSFA~1.0_1/lib/ant-contrib.jar;"

-Dweblogic.Name=AdminServer -Dweblogic.management.username=weblogic -Dweblogic.management.server="http://localhost:9001"

-Dweblogic.ProductionModeEnabled=true -Djava.security.policy="D:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.policy"

weblogic.Server


path in registry
----------------

D:\Oracle\MIDDLE~1\WLSERV~1.3\server\native\win\32;D:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;D:\Java\jdk1.6.0_20\jre\bin;D:\Ja

va\jdk1.6.0_20\bin;D:\Oracle\MIDDLE~1\WLSERV~1.3\server\native\win\32\oci920_8


Kindlu give me some guidance, How to resolve this issue.


Thanks in Advance
Krishna
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Started the windows service for admin server successfully, but the Admin Server is not started
 
Similar Threads
My Application won't work in Weblogic
Starting Weblogic server fine in Eclipse, but seems like project not being deployed.
Getting error when starting WLS 10.0
SEVERE: Dispatcher initialization failed-use Oracle weblogic server 11gR1 10.3.5
module failed to deploy on weblogic server