aspose file tools*
The moose likes General Computing and the fly likes quicktime failed to initialize. Error # 0. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » General Computing
Bookmark "quicktime failed to initialize. Error # 0." Watch "quicktime failed to initialize. Error # 0." New topic
Author

quicktime failed to initialize. Error # 0.

sai rama krishna
Ranch Hand

Joined: May 29, 2009
Posts: 251
When I click next button my application is going to next page with popup error message in IE8.0 as below

QuickTime unavailable
quicktime failed to initialize. Error # 0.
Please make sure QuickTime is properly installed on this computer.


Same application flow works fine on IE7.0. Please advise.Any ideas, suggestions, sample code, links, source code highly appreciated. Thanks in advance
Campbell Ritchie
Sheriff

Joined: Oct 13, 2005
Posts: 38902
    
  23
I presume you have Java enabled on IE8? What is your system classpath? QT has a tendency to alter the system classpath when it installs itself, which is a nuisance because you have to add .; to the classpath. It might only work if QT is in the classpath, but I would have thought that would have prevented it working for all versions of IE.

That is probably not a Java‑related problem, so I shall move this discussion elsewhere.
sai rama krishna
Ranch Hand

Joined: May 29, 2009
Posts: 251
Java is enabled.

I double checked as below

Launch Internet Explorer, click the “Tools” menu and select “Internet Options.”

2
Click the “Security” tab and choose "Custom Level."

3
Scroll down until you see “Scripting of Java applets” and check the box to enable.

4
Click “OK” to save this change and close the menu.

5
Restart your browser for the changes to take effect.



Some other computers it poped up windeos media player plug in update etc popup with OK button. Once we click OK next time onwards no more issues coming. I wonder in this particular computer why quick time plugin poped up with this error message. Can I make windows media player as default rathere than quicktime. Does that solve my issue. How to do that. Please advise



Campbell Ritchie
Sheriff

Joined: Oct 13, 2005
Posts: 38902
    
  23
You can maybe make WMP the default by opening it and finding a tick‑box saying “make default …”.
sai rama krishna
Ranch Hand

Joined: May 29, 2009
Posts: 251
I am using JCaptha to get the audio captcha text validation in that page.

http://jcaptcha.sourceforge.net/

Is there is a way I can enforce to use only particular media players, certain versions to avoid this annoying quick time message on client computers.

I see in the audio captcha servlet code within doGet() like

protected void doGet(HttpServletRequest request, HttpServletResponse response) throws ServletException, IOException
{

ServletOutputStream outStream = response.getOutputStream();

try
{
response.setContentType("audio/x-wav");





Interestingly it is working fine on all machines with IE7.0, IE8.0 browsers through windows media player(first time we have to click YES button for some windows security plugin related popup message though). But one test user machine on which windows media player is not validated and has quick time older version. In this test user machine security plugin related popup message also did not come to click YES first time. Test User is not willing to upgrade the quick time or validate the media player. I am not able to decide how to proceed in this situation.

Please advise
 
Consider Paul's rocket mass heater.
 
subject: quicktime failed to initialize. Error # 0.