File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Java in General and the fly likes Apache Commons Configuration Dependency Incompatibility Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » Java in General
Bookmark "Apache Commons Configuration Dependency Incompatibility" Watch "Apache Commons Configuration Dependency Incompatibility" New topic

Apache Commons Configuration Dependency Incompatibility

Dennis Putnam
Ranch Hand

Joined: Feb 03, 2012
Posts: 230
I am trying to use CompositeConfiguration class from Apache Commons and I'm getting a NoClassDefFoundError for NestableRunTimeException. In my reading on this problem there are a number of references to incompatible dependencies on versions of commons-lang. Unfortunately they all reference versions older than what I have. I am using commons-configuration-1.9.jar and commons-lang3-3.1.jar in my build path. What are the correct versions I should be using? TIA.
jQuery in Action, 3rd edition
subject: Apache Commons Configuration Dependency Incompatibility
It's not a secret anymore!