• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JBoss-as-7.1.1 unable to start

 
nir sharma
Ranch Hand
Posts: 72
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm new to JBoss and trying to configure it.
I unzipped JBoss-as-7.1.1 in root directory, from command prompt when I go to bin and type "standalone.bat" and press enter I see:
Calling "D:\jboss-as-7.1.1\bin\standalone.conf.bat"
and control return to the directory. when I check in browser (http://localhost:8080) the page is not displayed.
Though its running fine from eclipse.
Can anyone help me with this.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Seems like the batch file tripped over a command somewhere. Try editing the standalone.bat file, commenting out (or removing) the "@echo off" line. Then run it again. It will now echo the commands to the window. Look at the last thing that was done before you are returned to the command prompt, that should tell you what went wrong. If you can't figure it out, post the output.

Oh, and one more thing - make sure you are not running it in Eclipse when you do this - you'll end up with problems due to port conflicts. (Solving that is a different issue.)
 
nir sharma
Ranch Hand
Posts: 72
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


this is what I got when I tried to start the JBoss from command prompt after removing "@Echo off". I'm unable to understand what exactly is the problem. Can anyone help.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My guess is that you are hitting the findstr problem: https://community.jboss.org/wiki/FindstrCommandNotFound

In older versions of JBoss it was easier to comment out the lines in run.bat that used finstr, but it looks like you will instead have to get and install a copy of findstr.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic