aspose file tools*
The moose likes Web Services and the fly likes  How do I manually supply WSDL instead of returning automatically generated WSDL? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark " How do I manually supply WSDL instead of returning automatically generated WSDL? " Watch " How do I manually supply WSDL instead of returning automatically generated WSDL? " New topic
Author

How do I manually supply WSDL instead of returning automatically generated WSDL?

Megha Gulati
Greenhorn

Joined: Nov 11, 2012
Posts: 1
We have an application where we use Jboss5.1 with Axis 1.4.

In answer to my above question, <service name="Test" provider="java:RPC" >
...
<wsdlFile>/org/someone/res/mywsdl.wsdl</wsdlFile>
<!-- <wsdlFile>WEB-INF/wsdls/mywsdl.wsdl</wsdlFile> -->
...
</service> I found the following solution on the axis site :

I tried using <wsdlFile> with both absolute and relative paths separately. but I am not able to find the wsdl file anywhere.
PFB my wsdd details :

<service name="cpAPI" provider="java:RPC">
<parameter name="wsdlTargetNamespace" value="https://api.pbclearpath.com/api/services/cpAPI"/>
<parameter name="className" value="com.pb.clearpath.api.service.ClearPathAPIBean" />
<wsdlFile>/srv/webapps/axis/cpAPI.wsdl</wsdlFile>
<parameter name="allowedMethods" value="*" />

</service>

and on running it on localhost I get the following error :

AXIS error

Sorry, something seems to have gone wrong... here are the details:

Fault - Unable to find WSDL file or resource /srv/webapps/axis/cpAPI.wsdl

AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.generalException
faultSubcode:
faultString: Unable to find WSDL file or resource /srv/webapps/axis/cpAPI.wsdl
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}hostname:NOIME005GU-L1

I am quite new to axis and Jboss. Kindly explain which directory path we should give for <wsdlFile> . It can be any existing path or somewhere else?
Please help, its quite urgent. I hope I am able to explain the problem properly. I am new to both Jboss and axis.


 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How do I manually supply WSDL instead of returning automatically generated WSDL?
 
Similar Threads
AXIS Web Service Configuration for WebSphere 4.0 and WebSphere 5.0
Disable wsdl url in Axis 1.4
Not able to redeploy my web service in eclipse
Issue when deploying wsdd file
Axis 1 (1.4) Multiple method name in server-config.wsdd