• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Maven Pom Error - Can not find parent for Jersey

 
James Dekker
Ranch Hand
Posts: 221
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have Eclipse Juno, maven 2.2.1, and m2eclipse running on a Red Hat Linux platform...

Downloaded a simple example to build a Restful Hello World web service (which works on my home OS X computer) but for some odd reason, its not working on my Linux box.

Here's the pom.xml



When I go to the command line and type in maven compile, it throws this error:



Has anyone else experienced this same problem?

Any assistance, help, and / or tips are most appreciated...
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Any particular reason you are using that repository and not Maven Central? Try removing the <repositories> section and see if that works. (Though having looked at the POMs in both locations, they appear to be the same, so I am confused as to why the parent seems to have a null group and version. You might try clearing out your local repository, or at leats the com/sun directory - could be that the local repository is corrupted.)
 
James Dekker
Ranch Hand
Posts: 221
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Peter,

I got it working like this:

(1) Removing the repositories tag

(2) Adding newer versions of Jersey (1.15):



And yes, I did remove the .m2/repository (in order) to clear out the cache.

Many many thanks for the response!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic