This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes EJB and other Java EE Technologies and the fly likes Unable to retrieve EntityManagerFactory, everything configured correctly but does not run!!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Unable to retrieve EntityManagerFactory, everything configured correctly but does not run!!!" Watch "Unable to retrieve EntityManagerFactory, everything configured correctly but does not run!!!" New topic
Author

Unable to retrieve EntityManagerFactory, everything configured correctly but does not run!!!

Vinicius Abreu de Franca
Greenhorn

Joined: Nov 25, 2012
Posts: 3
I'm freaking out now! I can not find out why it fails to retrieve the PersistenceUnit. The worst thing is that when I run the EJB project profile tests, the "config-arquillian-glasfish", it runs perfectly, but when I run the complete project profile default, gives this error.
I've tried everything and apparently everything is configured correctly. The project is attached for those who want to try ... Please help me! Thank you. (Sorry for my english, I'm Brazilian)

Download EJBProject

Following is the stacktrace:
Vinicius Abreu de Franca
Greenhorn

Joined: Nov 25, 2012
Posts: 3
This error're taking me sleep! 2 weeks already! Here is the link to the SVN if someone have the courage to help me ...
SVN
Vinicius Abreu de Franca
Greenhorn

Joined: Nov 25, 2012
Posts: 3
I managed to find the error. The error was in maven (maven resources plugin). Thank you all.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Unable to retrieve EntityManagerFactory, everything configured correctly but does not run!!!
 
Similar Threads
ManyToMany merge problem
java update causing application failure
User Registration Problem with JPA
Persistence error at new entry from Netbeans CRUD application
Please somebody help me with JPA how to persist an entity which has default fields