This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Web Services and the fly likes SOAP: Only partial response from service Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "SOAP: Only partial response from service" Watch "SOAP: Only partial response from service" New topic
Author

SOAP: Only partial response from service

Mike Nowak
Greenhorn

Joined: Dec 21, 2011
Posts: 3
Hi!
I've got my java soap client, which theoreticaly works fine. I am getting a response from service: HTTP/1.1 200 OK and soap document like this:



Problem is that when i run my php soap client (on the same service) i get response like this:



and this above is response i expect. I've tried 3-4 methods to send request and recieve response, but all of them returns the same.
The interesting part is that after getting response from service (using my php client) i've got printed it on screen and is fine, but if i refresh page the response changes and looks exactly the same i've got in java client.
I stuck with this problem. Anyone maybe got an idea what is happening?

Regards
Mike
Mike Nowak
Greenhorn

Joined: Dec 21, 2011
Posts: 3
Ok, i know why response is getting short after page refresh - it's because webservice responding only once. Every next call is returning so called "empty response". And i figured that is exactly what i've got when i am trying to get response from webservice doing it in java (php works good).
My question is what could be the reasons getting an empty reponse from webservice while php returns correct answer? I suspect the "call" method, but could it be this?

Mike
Hikari Shidou
Ranch Hand

Joined: Jan 22, 2013
Posts: 88
How do you manage to make your WS have these attributes ID, InResponseTo, IssueInstant into samlp:Response element?
 
 
subject: SOAP: Only partial response from service
 
Similar Threads
Security in Axis 1.4
Soap format
WS-I monitor?
MTOM not working in Axis2
unable to connect to .Net web service using axis with java