• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Webservices container not able to recognizing the imports.

 
Nivi Chandana
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I am implemented java webservices, it is perfectly working fine. However I am trying to use some jars{external jars supplied by third party client - these jars working fine with standalone java program}, even though these jars been added in Java Build Path, some how calling code from webservices not able to recognize these external jar imports.


IDE - Eclipse Juno
JDK 1.7.0
Server - tomcat 7.0
Webservices - Apache CXF

I dont even know what to do where to turn to any any help much much appreciated, I need to make this code working before christmas eve,

Any help or suggestions much appreciated.

Thank you and regards
Nivi
 
Praful Thakare
Ranch Hand
Posts: 642
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I assume you are deploying it to tocmat in eclipse using Run As On server and your project is of Dynamic Web App type.
Do the following

Project->Properties --> Deployment Assembly -> Add and select relevant option, since you mention its in java build path it should be Java Build Path Entries.

cheers N Merry Xmas
-P
 
Nivi Chandana
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for your quick reply will try tomorrow and let you know the outcome.
Thank you and regards
Nivi
 
Nivi Chandana
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
Thank you from my bottom of my heart. your solution worked like a charm. Now my boss and me going to have good Xmas , thank you

Thank you and with regards
Nivi
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic