Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

"import org.apache.xpath.XPathAPI" can not be resolved.

 
Mani Raju
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I added Xalan-2.7.1.jar in buildpath in my project but still i am getting error for "import org.apache.xpath.XPathAPI;".
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34084
337
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mani,
That jar looks like it should contain te class. Have you tried unzipping the jar to make sure it is in there - and that the jar isn't corrupt?
 
Mani Raju
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jeanne Boyarsky wrote:Mani,
That jar looks like it should contain te class. Have you tried unzipping the jar to make sure it is in there - and that the jar isn't corrupt?


Yes, i extracted that jar file and checked that class. Required class exists in that jar file. I added this jar file in build path, still getting same error "Can not be resolved".

 
Mani Raju
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mani Raju wrote:
Jeanne Boyarsky wrote:Mani,
That jar looks like it should contain te class. Have you tried unzipping the jar to make sure it is in there - and that the jar isn't corrupt?


Yes, i extracted that jar file and checked that class. Required class exists in that jar file. I added this jar file in build path, still getting same error "Can not be resolved".



Yes, it resolved by adding xalan-2.7.1.jar file. Previously used jar file was corrupted. So that it didnt resolved. After adding fresh one, its working fine.

Thanks....................
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic