This week's book giveaway is in the Jobs Discussion forum.
We're giving away four copies of Java Interview Guide and have Anthony DePalma on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Tomcat 5.5.9 compatibility with Java 1.7 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 5.5.9 compatibility with Java 1.7" Watch "Tomcat 5.5.9 compatibility with Java 1.7" New topic

Tomcat 5.5.9 compatibility with Java 1.7

Shakun Nag

Joined: Dec 27, 2012
Posts: 1

I am working on a web application which has been build on JDK/JRE 1.6.0_06 and has been deployed on Tomcat 5.5.9 server. This application is on production since 2008. There is a plan to upgrade JDK/JVM to 1.7.0_07. My concern is that after the upgrade of JDK and JVM, will the application be deploying and running successfully on the aforesaid version of Tomcat i.e. 5.5.9 with out any issues? There is no information available either on java or on Apace Tomcat site regrading the compatibility of java 1.7 with tomcat 5.5.9. The only information I was able to collect is that Tomcat 5.5.9 requires minimum 1.4 version. There are no resources available for the maximum compatible version.

Please let me know if somebody has done such upgrade of their application or is aware of any known compatibility issue. I am afraid that we will need to upgrade tomcat as well along with upgrading to java 1.7. Do let me know if any more information is required.

PS: This is an urgent request to evaluate the feasibility. So we don't have much time, budget and resources to carry out a POC.

Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 17423

Welcome to the JavaRanch, Shakun!

In theory, all Java runtimes have backwards compatibility. In practice, there may be occasional glitches, so for maximum reliability one is best off using the indicated JVM. However, Java 1.6 will reach End-of-Life in February 2013, and at that point, Oracle won't fix any problems it may have, so it's a trade-off. They'd be somewhat more likely to fix compatibility issues in Java7 than fix native issues in Java6.

A bigger concern is the version of Tomcat that you are using. You're only 1 version behind on the JVM, but two versions behind on Tomcat, and for all I can recall, Tomcat 5.5 has already been end-of-lifed. At a minimum, relatively few people are left working with it on a daily basis, so the number of people here on the JavaRanch who can answer Tomcat 5.5 problems is not very high any more.

An IDE is no substitute for an Intelligent Developer.
I agree. Here's the link:
subject: Tomcat 5.5.9 compatibility with Java 1.7
jQuery in Action, 3rd edition