jQuery in Action, 2nd edition*
The moose likes JBoss/WildFly and the fly likes problem while deploying ejb3+jsf1.2+richfaces 3.3 based application on jboss 7.1.1 Final. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "problem while deploying ejb3+jsf1.2+richfaces 3.3 based application on jboss 7.1.1 Final." Watch "problem while deploying ejb3+jsf1.2+richfaces 3.3 based application on jboss 7.1.1 Final." New topic
Author

problem while deploying ejb3+jsf1.2+richfaces 3.3 based application on jboss 7.1.1 Final.

Gaurav Psl
Greenhorn

Joined: Jan 03, 2013
Posts: 8
hi all,

i am facing problem while deploying application on jboss 7.1.1 Final.

Server.log:
17:47:24,248 INFO [org.jboss.ws.common.management.DefaultEndpointRegistry] (MSC service thread 1-2) register: jboss.ws:context=app,endpoint=CoreWsImpl
17:47:26,046 INFO [org.jboss.web] (MSC service thread 1-2) JBAS018210: Registering web context: /app
17:47:27,422 INFO [javax.enterprise.resource.webcontainer.jsf.config] (MSC service thread 1-1) Initializing Mojarra (1.2_15.jbossorg-1-20111019-SNAPSHOT) for context '/protectoria'
17:47:31,375 SEVERE [javax.enterprise.resource.webcontainer.jsf.application] (MSC service thread 1-1) JSF1051: Service entry 'org.jboss.as.web.deployment.jsf.JsfInjectionProvider' does not extend DiscoverableInjectionProvider. Entry will be ignored.
17:47:31,385 INFO [javax.enterprise.resource.webcontainer.jsf.application] (MSC service thread 1-1) JSF1048: PostConstruct/PreDestroy annotations present. ManagedBeans methods marked with these annotations will have said annotations processed.
17:47:31,827 INFO [org.jboss.web] (MSC service thread 1-1) JBAS018210: Registering web context: /protectoria
17:47:31,860 INFO [org.jboss.as] (MSC service thread 1-2) JBAS015951: Admin console listening on http://127.0.0.1:9990
17:47:31,865 INFO [org.jboss.as] (MSC service thread 1-2) JBAS015874: JBoss AS 7.1.1.Final "Brontes" started in 98723ms - Started 1630 of 1715 services (84 services are passive or on-demand)
17:47:32,218 INFO [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "protectoria.ear"

my application is deployed but still not able to access on localhost it gives 404 when i access the url.
probably due to this severe problem i am not able to access the application.

please do suggest what i do to remove this issue??

Thanks in advance
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9955
    
163

Are you packaging any JSF related jars within your application? And what does your web.xml look like?

[My Blog] [JavaRanch Journal]
Gaurav Psl
Greenhorn

Joined: Jan 03, 2013
Posts: 8
Thanks for reply Jaikiran

i dont have JSF related jars in my ear, i am using jsf 1.2 module provided by JBoss 7.1.1 Final internally.

web.xml:

i have added below line of code for JSF1.2
<context-param>
<param-name>org.jboss.jbossfaces.JSF_CONFIG_NAME</param-name>
<param-value>Mojarra-1.2</param-value>
</context-param>

please do suggest?

Thanks,
Gaurav
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: problem while deploying ejb3+jsf1.2+richfaces 3.3 based application on jboss 7.1.1 Final.
 
Similar Threads
How to solve the problem specification
Deployment in JBoss 7.1.1.Final
Issue while deploying Application in Jboss 7.1
Page Not found error in Jboss 7
JBoss as 7.1.1 Server starts but deployment does not work - Have to reboot machine