Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

instructions to deploy jForum to weblogic server

 
Arie Morgenstern
Greenhorn
Posts: 12
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am wondering if anyone can help me with deploy instructions for jForum to a weblogic server.
See install instructions from jForum.net:


In this section is shown how to configure and install JForum using the Web Wizard interface. It is assumed that you have some knowledge on how to install/configure a Java servlet container (or already have one up and running), and the database is properly configured.

....

Unpacking

After the download, unpack the .ZIP file into your webapp's directory (or anyplace you want to put it). A directory named JForum- will be created, where is the version, which may be "2.0", "2.1.7" etc... this it just for easy version identification.

You can rename the directory if you want. The next step you should do is register the JForum application within your Servlet Container, like Tomcat. This document will use the context name "jforum", but of course you can use any name you want.


Unfortunately, my Weblogic knowledge is quite limited (I am working on it though), and so I do not know
you have some knowledge on how to install/configure a Java servlet container
.
Can you help me with a set of instructions?

Thanks,
Arie
 
Arie Morgenstern
Greenhorn
Posts: 12
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can't believe it, I figured it out!
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34401
346
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Arie,
That's great! Would you be willing to share a summary of what you did for the next person who wants to do it?
 
Arie Morgenstern
Greenhorn
Posts: 12
1
  • Likes 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well,
I logged into the Weblogic Server Console.
Went to Home Page >> Domain Configurations >> Your Deployed Resources >> Deployments.

On the Deployment page there is a button called "Install".
After pressing the button you are brought to the "Install Application Assistant" page.

Here was the thing I did not know. I thought you could only deploy WAR or EAR from this page. It appears you can also deploy a folder too.
I just pointed it to the unzipped JForum folder, and its up and running.

Arie
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34401
346
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Arie! I know it seems simple after the fact. But I'm sure others won't know that one key fact either. And you are going to save them a boatload of time.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic