• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Issues in deploying a web application on WASCE

 
Rachit Kumar Saxena
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This issue is causing a lot of problems.I would be extremely grateful if anyone could suggest something,in this regard:

Last night after installing WASCE on my Ubuntu 12.04,I decided to deploy a web app to test it.I made a folder inside the home directory(lets call it "Web Application").Inside it I made a test.html file and WEB-INF folder.Inside the WEB-INF directory,I created the web.xml and geronimo-web.xml(that specified the context root as /abc and welcome page as "test.html")
But when I open my browser to vist "http://localhost:8080/abc",I get a 404 Not Found,though WASCE is rightly installed(I checked the installation by visiting http://localhost:8080).Where am I going wrong?
 
Nam Ha Minh
Ranch Hand
Posts: 502
Eclipse IDE Firefox Browser Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What's WASCE? I heard this for the first time.

The URL http://localhost:8080/abc gives 404 error means that the application failed to deploy as context /abc. You need to check server's log file to see why it failed.
 
Rachit Kumar Saxena
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WASCE is Websphere Application Server Community Edition,a J2EE server(upgrade of Apache Geronimo and using Apache Tomcat as Container).
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic