This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

maven doesn't download Activation

 
Jean Donato
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello guys..

I'm with a freak thing here! hehe

I'm using maven 2.2.1 and Java 1.6.0_38 and I have one maven project. And when I run mvn clean install, it stay trying trying download activation-1.0.2.pom, and fail...

I solved this by putting the activation "by my hands" in the repo's folder...

I would like know why this happen...

This already happened with someone else?

[]'s
 
Jayesh A Lalwani
Rancher
Pie
Posts: 2756
32
Eclipse IDE Spring Tomcat Server
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you copy the error message?
 
Jean Donato
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it stay stopped here:
...
...
Downloading: http://myrepo/ivy/repository/activation/activation/1.0.2/activation-1.0.2.pom
289b downloaded (activation-1.0.2.pom)
Downloading: http://myrepo/ivy/repository/javax/activation/activation/1.0.2/activation-1.0.2.pom
755b downloaded (activation-1.0.2.pom)

And in the folder repo1/javax/activation/activation/1.0.2 and repo1/activation/activation/1.0.2 I have the files: activation-1.0.2.pom, activation-1.0.2.pom.sha1 and activation-1.0.2.pom.sha1.tmp

and If I stop the console and run again mvn clean install, the file sha1.tmp is removed from folder, then it stopped here:

[debug] execute contextualize
[INFO] [resources:resources {execution: default-resources}]
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e build is platform dependent!
[INFO] Copying 30 resources
 
Jayesh A Lalwani
Rancher
Pie
Posts: 2756
32
Eclipse IDE Spring Tomcat Server
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looks like there's something else going on that is causing maven to hang. Can you try running with verbose logging? Or get a thread dump while it's stuck
 
Jean Donato
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
in loop
==========================================
[DEBUG] While downloading javax.activation:activation:1.0.2
This artifact has been relocated to javax.activation:activation:1.0.2.
This file has been relocated based on maven recommendations: http:maven.apache.org.guiodes/mini/guide-coping-with-sun-jars.html
===========================================
 
Jayesh A Lalwani
Rancher
Pie
Posts: 2756
32
Eclipse IDE Spring Tomcat Server
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ahh there you go! if you spell correct that link, that link tells you everything you need to know Basically, Maven can redistribute Sun's jars. You will need to add Sun's maven repo in your list of repos. Here's more detail.
 
Jean Donato
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Jayesh,
So, I did this, but nothing.

The more stranger is that I have actvation in my maven-proxy repo.
 
Jayesh A Lalwani
Rancher
Pie
Posts: 2756
32
Eclipse IDE Spring Tomcat Server
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you paste your Pom here, I can try it when I get to work
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic