Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes Hadoop and the fly likes Hadoop on Windows Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » Hadoop
Bookmark "Hadoop on Windows" Watch "Hadoop on Windows" New topic
Author

Hadoop on Windows

Madhumitha Baskaran
Ranch Hand

Joined: Feb 27, 2010
Posts: 66
Hi,

I have configured Hadoop for Windows Cygwin. I guess configuration is successful. But when I start dfs or mapred,
I get errors like

/usr/local/hadoop/bin/hadoop-daemon.sh: line 30: pwd: Write error Bad file descriptor
/usr/local/hadoop/bin/hadoop-deamon.sh: line 35: /hadoop-config.sh: No such file or directory
/usr/local/hadoop/bin/hadoop-daemon.sh: line 38: /slaves.sh: No such file or directory

Sometimes its getting started.

If I run bin/hadoop , it is hanging. It is not starting at all.

If I run bin/hadoop hadoop-test.jar, it says "Could be replicated to 0 nodes instead of 1"

Thanks,
Madhu
Madhumitha Baskaran
Ranch Hand

Joined: Feb 27, 2010
Posts: 66
I also see that

DFS used 100%
DFS remaining 0%

Is it causing any issue here?

I have more space left in my C drive but
Tushar Sudake
Greenhorn

Joined: Jan 31, 2013
Posts: 2
I haven't tried this configuration myself ever [Windows + Cygwin + hadoop], but looks like $HADOOP_HOME is missing or not pointing to expected location [i.e. Hadoop installation dir].
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Hadoop on Windows