wood burning stoves 2.0*
The moose likes Beginning Java and the fly likes J6EE dukes-age Fails to Deploy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "J6EE dukes-age Fails to Deploy" Watch "J6EE dukes-age Fails to Deploy" New topic
Author

J6EE dukes-age Fails to Deploy

Ashley Bye
Ranch Hand

Joined: Jan 30, 2013
Posts: 46

I am trying to learn J6EE and am just going through the tutorials that come bundled with the download. However, I'm stuck just after the first hurdle and don't want to move on and try another example until I understand what I'm doing wrong/not doing. This particular example is called dukes-age from the firstcup-2.1 tutorials. When I run the project, I get the following error in the NetBeans run log:



I don't know how to either get rid of the application that is already using it (I moved my directory down one level after initially running it the first time, because I thought I may have put it in the wrong place) or tell NetBeans that I have only one application of that name, it just changed location on the hdd. If it's of any consequence, the J6EE referenced above is a link to /usr/glassfish/glassfish/docs.

I moved the directory because I got an error 404 the first time I ran the project. Looking through the tutorial, it says to place 'myexample' folder in the same level as the 'tut-install/example' directory, so I had to move it down a level from 'docs'. This is apparently where I will create the application. But the tutorial also says before that to create a folder anywhere for the example I will build, i.e. 2 directories. Nowhere else does it reference this second directory, or tell me how or where I set it in the project. All in all, I'm very confused.

I'd appreciate some help, thanks.


"Twenty years from now you will be more disappointed by the things you didn't do than by the ones you did do. So throw off the bowlines. Sail away from the safe harbor. Catch the trade winds in your sails. Explore. Dream. Discover." - Mark Twain
Ashley Bye
Ranch Hand

Joined: Jan 30, 2013
Posts: 46

I'll answer it in case anybody else finds this issue. Basically, some setting in NetBeans 7.2 has changed, and you can't configure RESTful resources by right-clicking it and selecting Configuration because it's greyed out after the wizard has run (how useful). So instead, you have to change the line `@javax.ws.rs.ApplicationPath("webresources")` to read resources in ApplicationConfig.java if you want to follow the tutorial as written. Alternatively, you can change the relative URL to webresources/dukesAge.

The answer was found here.

I'm not sure if the above is a bug with NetBeans,given my currently limited knowledge and understanding.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: J6EE dukes-age Fails to Deploy
 
Similar Threads
Beginner fail to deploy firstcup-dukes-age
The module has not been deployed. BUILD FAILED error problem
module has not been deployed
ERROR: The module has not been deployed
unable to connect project to database