GeeCON Prague 2014*
The moose likes JSP and the fly likes Custom Tag attribute - quote symbol expected issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » JSP
Bookmark "Custom Tag attribute - quote symbol expected issue" Watch "Custom Tag attribute - quote symbol expected issue" New topic
Author

Custom Tag attribute - quote symbol expected issue

Bechir Bejaoui
Greenhorn

Joined: Feb 06, 2013
Posts: 7
Hi
I'm trying to develop a custom tag with attributes, I encountred that problem
org.apache.jasper.JasperException: /CustomTagPage.jsp(12,41) quote symbol expected

Here is my custom tag class implementation



I subscribed it in a tlb file under /WEB-INF/lib/helloTagLib.tld



The custom tag works fine without attributes, however if I try to add attribute to the code and add the <attribute> tag I encounter this error

org.apache.jasper.JasperException: /CustomTagPage.jsp(12,41) quote symbol expected


Thank you



Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61315
    
  66

The problem is not in the declarations of the tag, but in its use. Which is the one thing you have not shown us.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Bechir Bejaoui
Greenhorn

Joined: Feb 06, 2013
Posts: 7
Bear Bibeault wrote:The problem is not in the declarations of the tag, but in its use. Which is the one thing you have not shown us.


Yes in fact, I discovered the issue, when I declared the attribute, I miss used it as you said

<customLibrary:customTag attribute_name= 1> in stead i have to add quotes to attribute_name= "1"
 
GeeCON Prague 2014
 
subject: Custom Tag attribute - quote symbol expected issue