This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Struts and the fly likes Struts 2 Validation stopped working mysteriously (First Struts2 Project) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts 2 Validation stopped working mysteriously (First Struts2 Project)" Watch "Struts 2 Validation stopped working mysteriously (First Struts2 Project)" New topic
Author

Struts 2 Validation stopped working mysteriously (First Struts2 Project)

Chris Burdick
Greenhorn

Joined: Feb 12, 2013
Posts: 1
I'm working on my first Struts2 project and I am having an issue getting the validation to work. It was actually working great last night, but when I opened up Eclipse today it is mysteriously skipping validation altogether... no error messages or exceptions. I haven't changed anything. The validation xml is in the same package location at the action file.

I also tried importing a WAR file with working code that I created last night, although when I imported the working code, the validation still doesn't work... I'm at a bit of a loss.

I am trying to validate that the Operating System and OS Version fields are required and the Notes field is optional, but now it's executes the add method and adds the data to the database.

Anything I might be missing here? Any help would be much appreciated.


OsAction.java


OsAction-validation.xml



struts.xml



entry.jsp



result.jsp
 
 
subject: Struts 2 Validation stopped working mysteriously (First Struts2 Project)
 
Similar Threads
validation in struts2
xml form validation UI error message not shown?
required validator not working
result display error
validation problem in ActionClass-validation.xml