Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes Portals and Portlets and the fly likes problem with simple JSR-168 portlet on Weblogic 10.3.5 portal server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Java » Portals and Portlets
Bookmark "problem with simple JSR-168 portlet on Weblogic 10.3.5 portal server" Watch "problem with simple JSR-168 portlet on Weblogic 10.3.5 portal server" New topic
Author

problem with simple JSR-168 portlet on Weblogic 10.3.5 portal server

Boris Friedman
Greenhorn

Joined: Feb 17, 2013
Posts: 1
I am learning portlet programming using "A good book on JSR-168 portlet development" by Cameron McKenzie. I have a very simple portlet with the following Java code:



The portlet forwards to "NumberGuesser.jsp" with the following code:




The JSP is supposed to redirect back to the portlet after a number was entered and the user clicked "submit". Say, if the user entered "2" and, since "number" parameter is passed, it is supposed to say "You guessed 2...". However, after I click submit, the view does not change, and number parameter is still null, it still shows the original JSP view "Please enter your guess...".


Does anyone have an idea what I am doing wrong?

I am using Weblogic 10.3.5 portal and Eclipse to deploy the portlet to the localhost.

I will really appreciate your help.

Thanks a lot
Boris
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: problem with simple JSR-168 portlet on Weblogic 10.3.5 portal server