aspose file tools*
The moose likes Other Application Frameworks and the fly likes DataAccess using Spring... Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » Other Application Frameworks
Bookmark "DataAccess using Spring..." Watch "DataAccess using Spring..." New topic
Author

DataAccess using Spring...

Senthil Narayanaswamy
Greenhorn

Joined: Apr 15, 2007
Posts: 4
I am trying to setup a Spring Application in the IBM RAD 6.0. The application works fine. Then i tried to connect to databse without using the connection pool and it worked fine. The problem started when i tired using the connection pool and since then i'm not able to connect to database. The Database is Sybase.

In the config file this is what i have...

<bean id="achManDao" class="com.keybank.der.ach.dao.AchManagerDaoJdbc">
<property name="dataSource">
<ref bean="dataSource"/>
</property>
</bean>
<bean id="dataSource" class="org.springframework.jndi.JndiObjectFactoryBean">
<property name="jndiName"><value>jdbc/SYBASDB</value></property>
<property name="jndiTemplate">
<ref bean="jndiTemplate" />
</property>
</bean>
<bean id="jndiTemplate"
class="org.springframework.jndi.JndiTemplate">
<property name="environment">
<props>
<prop key="Context.INITIAL_CONTEXT_FACTORY">
com.ibm.websphere.naming.WsnInitialContextFactory
</prop>
</props>
</property>
</bean>

The exception i'm getting is:

[6/12/07 16:26:17:293 EDT] 00000039 SystemErr R org.springframework.jdbc.CannotGetJdbcConnectionException: Could not get JDBC Connection; nested exception is java.sql.SQLException: JZ004: User name property missing in DriverManager.getConnection(..., Properties).DSRA0010E: SQL State = JZ004, Error Code = 0DSRA0010E: SQL State = JZ004, Error Code = 0
java.sql.SQLException: JZ004: User name property missing in DriverManager.getConnection(..., Properties).DSRA0010E: SQL State = JZ004, Error Code = 0DSRA0010E: SQL State = JZ004, Error Code = 0;

I know it looks like that i'm missing User Name. But in IBM RAD 6, i did set up User name and password for this datasource.
Below is my DataSource.

Name JNDI name Description
SYBASDB jdbc/SYBASDB New JDBC Datasource

I'm not sure whether i'm missing anything. Can anyone help me out.
 
 
subject: DataAccess using Spring...