Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Maven locale repo doesn't take in account with artifactory

 
Adrien Ruffie
Ranch Hand
Posts: 92
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all, I have a 2 module like this:



my "myapp-install-wizard" depend of "myapp-webapp" SNAPSHOT,

I already have a "mvn clean install" of myapp-webapp SNAPSHOT I my locale .m2 repo
by when I try to compile my "myapp-install-wizard" the following stack trace is logged and my build failed:

[ERROR] Failed to execute goal on project myapp-install-wizard: Could not resolve dependencies for project com.myapp:myapp-install-wizard:jar:Head-SNAPSHOT: Could not find art
ifact com.myapp:myapp-webapp:jar:Head-SNAPSHOT in snapshot (http://192.168.1.160:8081/artifactory/libs-snapshot) -> [Help 1]

Normal I don't want to deploy my webapp snapshot in the artifactory, but I want to take the snapshot in my locale .m2 repository ... how I can force maven to take the snapshot in locale repo
if isn't found in remote artifactory repo ?

Thank & best regards,

Adrien
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maven will always look in the local repository before going off to look in the remote repository (artifactory). Is yous snapshot in the local repository? Did you double-check that it's there? Did you built it (the snapshotted artifact) using "mvn install"?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic