• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JBoss 3.2.3 is not starting as well as build fails ???? EJB build fails or JBoss fails ???

 
Rahul Shilpakar
Ranch Hand
Posts: 132
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Backround detail:

Application Server: JBoss 3.2.3

IDE: Eclipse Ganymede v. 3.4.1

Project: EJB project EJB v. 2.0

Program: Session Bean Program



Elaboration: I create a TigerBean class. Now they say it will automatically create TigerSession and the build fails. The JBoss server failed to start.

may I know what is going wrong. In my EJB project it shows Red Mark also in ejb-jar.xml

When I simply start the JBoss server it shows following message:

1. Server JBoss v3.2.3 at localhost failed to start.

2. At console: It shows like this

16:43:28,296 INFO [Server] Starting JBoss (MX MicroKernel)...
16:43:28,302 INFO [Server] Release ID: JBoss [WonderLand] 3.2.3 (build: CVSTag=JBoss_3_2_3 date=200311301445)
16:43:28,306 INFO [Server] Home Dir: D:\sftwrs\application server\jboss\jboss-3.2.3
16:43:28,307 INFO [Server] Home URL: file:/D:/sftwrs/application server/jboss/jboss-3.2.3/
16:43:28,309 INFO [Server] Library URL: file:/D:/sftwrs/application server/jboss/jboss-3.2.3/lib/
16:43:28,313 INFO [Server] Patch URL: null
16:43:28,314 INFO [Server] Server Name: default
16:43:28,314 INFO [Server] Server Home Dir: D:\sftwrs\application server\jboss\jboss-3.2.3\server\default
16:43:28,372 INFO [Server] Server Home URL: file:/D:/sftwrs/application server/jboss/jboss-3.2.3/server/default/
16:43:28,373 INFO [Server] Server Data Dir: D:\sftwrs\application server\jboss\jboss-3.2.3\server\default\data
16:43:28,373 INFO [Server] Server Temp Dir: D:\sftwrs\application server\jboss\jboss-3.2.3\server\default\tmp
16:43:28,374 INFO [Server] Server Config URL: file:/D:/sftwrs/application server/jboss/jboss-3.2.3/server/default/conf/
16:43:28,375 INFO [Server] Server Library URL: file:/D:/sftwrs/application server/jboss/jboss-3.2.3/server/default/lib/
16:43:28,380 INFO [Server] Root Deployment Filename: jboss-service.xml
16:43:28,402 INFO [Server] Starting General Purpose Architecture (GPA)...
Failed to boot JBoss:
javax.management.InstanceNotFoundException: JMImplementation:service=LoaderRepository,name=Default
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(Unknown Source)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(Unknown Source)
at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(Unknown Source)
at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:499)
at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:335)
at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
at org.jboss.Main.boot(Main.java:150)
at org.jboss.Main$1.run(Main.java:395)
at java.lang.Thread.run(Unknown Source)


My ejb module xml file looks like this:


 
Jaikiran Pai
Marshal
Pie
Posts: 10444
227
IntelliJ IDE Ubuntu
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is this a clean installation of JBoss AS? By the way, why are you using 3.2.3 version which is extremely old. Why not use the latest AS7 version?
 
Rahul Shilpakar
Ranch Hand
Posts: 132
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

Thank you but If I use new version of JBOSS will it support the Eclipse 3.4.1 & EJB 2.0 and xDoclet 1.2.3?
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic