aspose file tools*
The moose likes Other Open Source Projects and the fly likes Fuse ESB issues Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "Fuse ESB issues" Watch "Fuse ESB issues" New topic
Author

Fuse ESB issues

rodd manning
Greenhorn

Joined: Mar 06, 2007
Posts: 15
Good Morning,

I downloaded the beta version of jboss fuse (jboss-fuse-6.0.0.redhat-015) and decided to try out the cbr sample.I run maven command "mvn clean install" and then started up the jboss fuse via commad line.At the karaf command line i tried to do the following


osgi:install -s fab:mvnrg.jboss.fuse.examples/cbr/6.0.0.redhat-015


It stays stuck at that for a while and then throws a error


Error executing command: Error installing bundles: Unable to install bundle fab:mvnrg.jboss.fuse.examples/cbr/6.0.0.redhat-015


When i look at the log file i see the following


org.sonatype.aether.resolution.ArtifactDescriptorException: Failed to read artifact descriptor for org.jboss.fuse.examples:cbr:pom:6.0.0.redhat-015


Caused by: org.apache.maven.model.resolution.UnresolvableModelException: Could not transfer artifact org.jboss.fuse.examples:project:pom:6.0.0.redhat-015 from repos1 (http://repo.fusesource.com/nexus/content/groups/public): Error transferring file: Connection timed out: connect

at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:119)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

at org.apache.maven.model.building.DefaultModelBuilder.readParentExternally(DefaultModelBuilder.java:819)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

at org.apache.maven.model.building.DefaultModelBuilder.readParent(DefaultModelBuilder.java:670)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:308)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:232)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:299)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

... 32 more

Caused by: org.sonatype.aether.resolution.ArtifactResolutionException: Could not transfer artifact org.jboss.fuse.examples:project:pom:6.0.0.redhat-015 from repos1 (http://repo.fusesource.com/nexus/content/groups/public): Error transferring file: Connection timed out: connect

at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:488)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:190)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:115)[71rg.fusesource.fabric.fab.fab-osgi:7.2.0.redhat-015]

... 37 more



I have my local repository in a non standard location and have the value in my settings.xml file.The settings.xml file also has the path to my in company nexus repository from which i had expected the application to pull/resolve the above.I also have the following settings changed in my "org.ops4j.pax.url.mvn.cfg" file


org.ops4j.pax.url.mvn.settings=file:/Maven/settings.xml


I am not sure why it is still going out to fusesource to resolve stuff.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Fuse ESB issues