This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes JBoss/WildFly and the fly likes JBoss war WEB-INF/lib jar loading problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss war WEB-INF/lib jar loading problem" Watch "JBoss war WEB-INF/lib jar loading problem" New topic
Author

JBoss war WEB-INF/lib jar loading problem

rajareddya reddy
Ranch Hand

Joined: Jul 23, 2011
Posts: 49
Dear all,

I am using maven to build WARand deploying war in JBOSS 5.X. But one the jars placed in WEB-INF/lib of war file not detecting.
How to fix this jar loading problem.

Kindly advice.
Jayesh A Lalwani
Bartender

Joined: Jan 17, 2008
Posts: 2341
    
  28

What do you mean by "not detecting". Is it giving you a ClassNotFoundException?
rajareddya reddy
Ranch Hand

Joined: Jul 23, 2011
Posts: 49
Yes, I am getting ClassNotFoundexception. Jar is not a thirdpatry jar

I tried below steps to fix issue.But NO LUCK.

1)updated classpath of WAR META-INF with jar paths located in WEB-INF/lib folder.
2) added jars in jboss server lib folder
3)Added classpath at jboss start up script
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10067
    
163

And please post the relevant stacktrace.

[My Blog] [JavaRanch Journal]
rajareddya reddy
Ranch Hand

Joined: Jul 23, 2011
Posts: 49
I am getting below user defined exception. I am getting this exception when jar1 is calling class in jar2. But jar1 is loading but jar2 NOT.Both jars are placed in WEB-INF LIb folder.
When I tested with the same jars using standalone program.It is working .But in JBOSS only we are getting this class loading issues.

Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61092
    
  66

It's WEB-INF/lib -- not WEBINF/LIB or WEBINF LIB.

I fixed the topic title for you.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
rajareddya reddy
Ranch Hand

Joined: Jul 23, 2011
Posts: 49
I added jars in WEB-INF/lib folder only.For readablity purpose I have mentioned WEBINF instead of WEB-INF

Kindly help anybody
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61092
    
  66

Please read AvoidRedHerrings
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

The error message is coming from a class named: com.crimsonlogic.sigma.terminal.CalculateException
That class is not part of JBoss AS. You need to find out who developed this class and ask them. (I Googled "crimsonlogic" and came up with a supplier of business and government applications, is that what you are using?)


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JBoss war WEB-INF/lib jar loading problem