Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JBoss war WEB-INF/lib jar loading problem

 
rajareddya reddy
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear all,

I am using maven to build WARand deploying war in JBOSS 5.X. But one the jars placed in WEB-INF/lib of war file not detecting.
How to fix this jar loading problem.

Kindly advice.
 
Jayesh A Lalwani
Rancher
Posts: 2756
32
Eclipse IDE Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What do you mean by "not detecting". Is it giving you a ClassNotFoundException?
 
rajareddya reddy
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, I am getting ClassNotFoundexception. Jar is not a thirdpatry jar

I tried below steps to fix issue.But NO LUCK.

1)updated classpath of WAR META-INF with jar paths located in WEB-INF/lib folder.
2) added jars in jboss server lib folder
3)Added classpath at jboss start up script
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And please post the relevant stacktrace.
 
rajareddya reddy
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am getting below user defined exception. I am getting this exception when jar1 is calling class in jar2. But jar1 is loading but jar2 NOT.Both jars are placed in WEB-INF LIb folder.
When I tested with the same jars using standalone program.It is working .But in JBOSS only we are getting this class loading issues.

 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64843
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's WEB-INF/lib -- not WEBINF/LIB or WEBINF LIB.

I fixed the topic title for you.
 
rajareddya reddy
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I added jars in WEB-INF/lib folder only.For readablity purpose I have mentioned WEBINF instead of WEB-INF

Kindly help anybody
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64843
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please read AvoidRedHerrings
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The error message is coming from a class named: com.crimsonlogic.sigma.terminal.CalculateException
That class is not part of JBoss AS. You need to find out who developed this class and ask them. (I Googled "crimsonlogic" and came up with a supplier of business and government applications, is that what you are using?)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic