• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

How to change glassfish application server default browser icon?

 
Haytham Douaihy
Greenhorn
Posts: 14
Eclipse IDE Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can we set a default browser-tab icon for applications running under glassfish server?
 
Michael Ernest
High Plains Drifter
Sheriff
Posts: 7292
Netbeans IDE VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Add a favicon.ico file, containing the image you want shown, to the root context of your application. This should work in any standardized web application container.
 
Haytham Douaihy
Greenhorn
Posts: 14
Eclipse IDE Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
unfortunately with glassfish, this solution do not work!
the only solution till now is to embed it inside the html code using the link tag referencing the favicon.ico to be used...
thanks anyways
 
Michael Ernest
High Plains Drifter
Sheriff
Posts: 7292
Netbeans IDE VI Editor
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I bet if you look in your logs you'll see the file is being accessed if it's in the right place.

Possibly your GlassFish installation does not define the proper MIME type for a .ico file Try adding:

<mime-mapping>
<extension>ico</extension>
<mime-type>image/vnd.microsoft.icon</mime-type>
</mime-mapping>

to your default-web.xml file and see if that helps.
 
Haytham Douaihy
Greenhorn
Posts: 14
Eclipse IDE Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Inside the default-web.xml, there is already a mime definition for 'ico', which is

so i left it, and i added the type that you provided. then i put the favicon.ico under the context-root of my application, then restarted the server, but no change also... maybe am missing something else?

about the log file, at which log file should i look? i tried the default server.log but nothing inside referencing a missing ico image...
 
Haytham Douaihy
Greenhorn
Posts: 14
Eclipse IDE Java Oracle
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Michael,
I was using Firefox for testing, and i don't know if there is a special configuration or issue with favicon on Firefox, but what i know, that after testing your suggestion using google chrome, i find it well working...
thanks!!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic