wood burning stoves 2.0*
The moose likes Spring and the fly likes WebAppRootKey Not Working On Mac, but Works on Windows? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Frameworks » Spring
Bookmark "WebAppRootKey Not Working On Mac, but Works on Windows?" Watch "WebAppRootKey Not Working On Mac, but Works on Windows?" New topic
Author

WebAppRootKey Not Working On Mac, but Works on Windows?

Mike London
Ranch Hand

Joined: Jul 12, 2002
Posts: 1043
I deployed the exact same WAR file to Tomcat 7 under Windows and under Mac OSX 10.8.3.

In Windows, using the code below in web.xml, the WebAppRootKey worked fine and set the log directory (in same folder as webapps) was found with no problems.

Yet, the exact same war file with same log directory structure on the mac does not work and gives the error: 'java.io.FileNotFoundException: /../../customlogs/thedview.log (No such file or directory)"

How could this happen?

I also tested with Tomcat 6 on the mac with the same results.

Absolutely stumped.

Look forward to any and, believe me, all, suggestions!

Thanks,

-mike


 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WebAppRootKey Not Working On Mac, but Works on Windows?
 
Similar Threads
how to deploy portlet in pluto portal with tomcat server
Adding/changing java classes on eclipse project
application. getInitParameter()
How can make .war file for IBM websphere configurable?
Deploying Struts app on Linux server