aspose file tools*
The moose likes JDBC and the fly likes MS SQL jdbc drivers and JRE compatibility Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "MS SQL jdbc drivers and JRE compatibility" Watch "MS SQL jdbc drivers and JRE compatibility" New topic
Author

MS SQL jdbc drivers and JRE compatibility

Andres Delrotti
Ranch Hand

Joined: Aug 11, 2005
Posts: 139


hello,

This is the current setup of one of our old applications

JRE: 1.3
Deployed at Websphere 5.1
Database: MS SQL 2000
JDBC drivers used: msbase.jar, mssqlserver.jar, msutil.jar

Now, there is a plan to upgrade the database to MS SQL 2008 R2. We found out that those three jdbc drivers we are using would not work in 2008 R2. The available JDBC driver for MS SQL 2008 R2 would be sqljdbc.jar

The problem is, from the specs we saw that sqljdbc.jar is only compatible for java 5 and higher. With this it seems we need to upgrade our application to at least java 5 and be deployed on a higher version of Websphere
to be able to connect to MS SQL 2008 R2. This approach doesnt seem practical. Do you guys know any other workaround for this?

thanks
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: MS SQL jdbc drivers and JRE compatibility